GL-AR150 as Switch and AP Only

hi, i have an GL-AR150
I would need both ports (lan and wan) to work as a switch (I need vlan)
and wifi as AP
it's possible?

Yes, it's possible.

can someone share a config of /etc/config/network ?
this is my actual /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd71:2745:1c53::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth1'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option macaddr 'e4:95:6e:41:ab:a5'
        option default_macaddr 'e4:95:6e:41:ab:a5'
        option hostname 'GL-AR150-ba4'
        option ipaddr '192.168.14.254'

config interface 'wan'
        option ifname 'eth0'
        option proto 'dhcp'
        option hostname 'GL-AR150-ba4'
        option metric '10'

config interface 'wan6'
        option ifname 'eth0'
        option proto 'dhcpv6'

config interface 'guest'
        option ifname 'guest'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.9.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config route
        option interface 'wan'
        option target '192.168.1.0'
        option netmask '255.255.255.0'
        option gateway '192.168.1.254'

Doesn't your device support VLANs?

Do you have page Network > Switch in LuCI? Can you make VLANs there?

i dont have Network > Switch but i am sure that my hardware support VLAN!

gl firmware or stock openwrt? if gl firmware switch configuration is under advanced..

or you just need to edit network so both wan and lan port act as a switch

config interface 'lan'
option type 'bridge'
option ifname 'eth1.X eth0.X' ""where X is your vlan""
option proto 'static'
option netmask '255.255.255.0'
option ip6assign '60'
option macaddr 'e4:95:6e:41:ab:a5'
option default_macaddr 'e4:95:6e:41:ab:a5'
option hostname 'GL-AR150-ba4'
option ipaddr '192.168.14.254'

remove wan and wan6 and routing from your config.. or try to be more specific on your needs..

you can always use option ifname 'ethX.X' ""where X is your vlan"" in your config to setup vlans

hi thx u for reply
i use stock openwrt
i attach an image of want i wanna do

help me!
plxxxxx :slight_smile:

i don't understand what you want to achieve exactly and i don't own your device, i was just giving you some hints how you could set up vlans.

i found this doing a quick search that's all.


cheers

I am not suggesting this will solve your problem, but what version of OpenWrt you have?