GIT and Clone installation

Thank you for very prompt reply.

I did somehow manage to install nano a couple of weeks back but forgotten how I did it. This reference to W I must admit to being confused by. Obviously openwrt doesn't have a BASH history for me to refer back to.



1 Like

The OpenWrt build system runs on an x86-64 and cross compiles. Then the binaries are copied to the target system. Compiling directly on the target system is not supported.


Got to admit that although I am pretty familiar with APT, PACMAN and DNF compiling is a mystery to me. Are you saying my drivers for the TP-Link adapter will need to be compiled on a conventional system and then transferred to the openwrt on my R-Pi?


define conventional.

it needs to be cross compiled, somewhere, on a x86-64 platform.


Conventional I meant laptop running Ubuntu maybe.


yeah, it could be used for the task.

1 Like

OK, so I have got this correct then; openwrt is not able to GIT clone and then make install a driver via its own command line?


Just reading this, never done this before.


depends on the driver.

cross compiling isn't much different than any compiling.
but openwrt is a large target/project.

If you want to save some (or a lot) time, get a supported adapter :wink:

1 Like

Reading generic material about Linux kernel cross-compiling is unnecessary and fruitless, as OpenWrt has a highly tailored compiling environment/toolchain, which you NEED to use.

Start with

(note that compiling unsupported kernel drivers for wifi is not trivial. I doubt that you will succeeed if the driver for the adapter is not yet supported)


Thank you.

I bought this adapter as I read that TP-Link devices were well supported by Linux, I inadvertently took that to mean it would be recognised. So far easy enough with Ubuntu and Mate, each on different computers.


Sure, you are talking about desktop distros with gigabytes of various drivers, but just for x86_64. They have the possibility of storing/using several concurrent versions of a library etc. And a single CPU architecture to compile for.

OpenWrt typically needs to fit everything into something like 6-10 megabytes fo flash space, and does that separately for 30+ mobile/embedded processor architectures. That means a highly tailored toolchain for cross-compiling stuff differently for each CPU variant.

Now you need a driver for Raspberry Pi (of which various versions use slightly different CPUs), compiled to match the exact kernel in the OpenWrt revision you are using, plus the exact C library version used in kernel and user-space compilation. Totally different than the x86_64 with no limit on storage space. Sadly.

It is all a learning curve. The openwrt for the R-Pi recognises nicely the Pi onboard wifi and I used the setup as a project to make a wifi router. Worked nicely but the Pi WiFi module has obviously limited range.

The TP-Link adapter is merely an experimental project to see if and how much better range I end up getting.

May return the device, shall see.


Well, this is community project. All devices and drivers have been imported by someone... can be the one investigate/tailor/modify/configure the specific driver for that new USB wifi device you need to have :wink:

1 Like

I know how to modify the driver behind the wheel of a car (Was an instructor for many years) but have no idea how to modify a driver behind a device :joy: :joy:

Mind you, who knows.


wait, what you really wanted is a driver for tplink ac600 - It looks like it use rtl8814au
or mt7610u (tplink has quite a revisions of ac600 usb dongle.)

for rtl8814au this repository will do the job?, and for mt7610u kmod-mt76x0u from opkg will be enough

what wifi dongle exactly you have, @Geffers


TP-Link Archer T2U Plus. There is a driver named kmod-rtl-8812au-ct which I installed.

Shows up with lsusb but still no luck working.

I'll give your suggestion a try.


Where did you see these references? I can't see the reference to rtl8814au and can't find it in the Luci software database. Installed kmod-mt76x0u via Luci but adapter still not working but, as mentioned, shows up with lsusb.

Do I need to install firmware too?


sorry it was rtl8811au

but looks like those 3rd party driver doesn't support AP mode (host a wifi)

Annoyingly I bought this device as I read up and saw a report that TP-Link support Linux well. Think the RaspberryPi (which is what I have opeen-wrt installed on) use Broadcom chipsets so the wifi shows up no problem.

Might unfortunately have a surplus wifi device :roll_eyes: