Getting WDS working with the verizon router


Client PC connected to OWRT

My OWRT is a Asus AC1300. I have a verizon router/modem combo that does DHCP and Wi-Fi. I followed instructions in LuCl. It shows the OWRT as connected to the router in “associated stations”

Client "Fios-YU0EN-5G" (wlan1)

but can't ping the router in diagnostics.
which interface should I assign the wireless connection when adding it, because by default it creates interface WWAN? should I bridge it to LAN and also assign it to the LAN firewall rule?

Lan, since they're on the same subnet.

Ok. That’s done. So just leave the WWAN interface? Can I delete it? What does it even stand for, wireless WAN?

How do I test if the WDS bridge works? I’m pinging the router and nothing. Is there a way to see the bridging process under the hood?

Different vendor's versions of WDS usually do not interoperate. OpenWrt WDS can only be certain to work if it is OpenWrt on both ends.

If the WDS is up, brctl show should show a wlanX interface has been created and added to the br-lan bridge. You do not need to manually define an interface or change anything in the firewall since a bridge operates at layer 2, while the firewall is layer 3.

Also you can use iwinfo wlanX as to see if the wifi is connected. Though a connection doesn't mean that data will pass.

Ok, thanks.
Here is the output. But still can’t ping

root@OpenWrt:~# iwinfo wlan1 info
wlan1 ESSID: "Fios-YU0EN-5G"
Access Point: A8:5E:45:65:BB:94
Mode: Client Channel: 157 (5.785 GHz)
Center Channel 1: 155 2: unknown
Tx-Power: 30 dBm Link Quality: 64/70
Signal: -46 dBm Noise: -102 dBm
Bit Rate: 866.7 MBit/s
Encryption: WPA2 PSK (CCMP)
Type: nl80211 HW Mode(s): 802.11nac
Hardware: 168C:003C 168C:4019 [Qualcomm Atheros IPQ4019]
TX power offset: none
Frequency offset: none
Supports VAPs: yes PHY name: phy1

root@OpenWrt:~# brctl show
bridge name bridge id STP enabled interfaces
br-lan 7fff.a85e4565bb94 no eth0