Getting pcie card with 5V lanes recognized (mikrotik rbm33g + unielec mt7612u)

Hi there,
As the title says, it tried to get a MT7612 card from unielec work together with a Mikrotik rbm33g router.
Both chipsets would make a nice combination, but sadly i had no success so far.
What i tried:

  • putting in other pcie card. this works (they show up in dmesg and work if i install the correct modules)
  • switching the sockets
  • running latest snapshot (some mt7621 pcie related fixes are not in release)
  • I am aware, that the unielec card need 5V at the pins so i connected 5V to the pins at the first socket, after checking, that they are not connected elsewhere.
  • i also tried taping pins, as recommended for some LTE modems, but after i found the pinout of the unielec card, it was obvious, that it wouldn't help.

Why is the slot seem as empty? Is the card broken, or did unielec just spare out some parts and ignored so specifications? As far as i can tell from other forum posts here, the card seem to work fine together with an unielec router.

After all that, i just concluded to change the card, but on the other hand the problem caught my interest.
So i wanted to poke around a bit more an wrote this post. Maybe someone else has another idea or i am just missing something.

Any hints would be nice.

The problem seems to be stranger, then i thought before:
The cards are correctly detected on other devices, independently of any 5V lane for the power amplifiers.
On the other hand, other wifi cards correctly show up in the kernellog of the rbm33g.

So both devices are ok and the problem resides in the combination of the specific card and the rbm33g.