Getting OpenWrt to Run on a Linksys WRT1200AC

Here is a quick rundown of what I've done so far:

  • Connected my Windows 10 laptop to the router via Ethernet cable
  • Set a static IP address on my laptop
  • Downloaded the "Firmware OpenWrt Installed" from
  • NOTE: This is the file called openwrt-19.07.7-mvebu-cortexa9-linksys_wrt1200ac-squashfs-factory.img
  • Selected the file using the "Router Firmware Update" function in the default Linksys UI
  • Clicked start and clicked through the "unrecognized file name" and "update firmware" warnings

This appears to be what everyone else has done but it doesn't seem to work for me. Here is what happens:

  • The router UI shows a progress bar and then says that it is restarting
  • I click OK and the router shows a spinner and says "waiting"
  • Eventually this times out and and shows an error message
  • At no point was I able to connect to the OpenWrt UI either via my browser or with SSH via PuTTY
  • At this point I waited about 5 minutes and I was still unable to connect
  • Then I power cycled and waited another 5 minutes and was still unable to connect
  • At no point was I able to successfully ping the router
  • After this I power cycled a few more times and eventually it booted with the original firmware instead of OpenWrt

I just flashed my (new to me) WRT3200ACM a few days back, 19.07.6 factory worked

At least these routers have dual firmware. What happened was: assuming factory FW was in partition 1, you flashed OpenWRT in partition 2 and tells the bootloader to boot from partition 2. "3 failed boots" puts the default boot back to partition 1 which booted back up w/ factory FW loaded

PS: if the new firmware turns on and stays on, but with no connectivity, I don't think that count towards a "failed boot"

Just for debug purpose, maybe try 19.07.6 factory image?

The way that worked best for me to switch back to the "old FW partition", is "3s power on, 1s off" for 3 cycles, and the 4th power on just turn it on and leave it, should boot right up to the old FW :slight_smile:

Just to add to what @dominick-han has said, I have a wrt1200 and I’ve never seen the unrecognized file name warning when flashing OpenWrt from linksys stock going back to the 15.. versions, I just flashed 19.07.7 from 19.07.6 today and it’s running fine so as Dominick mentioned that’s probably the easiest thing to do.