Getting disconnected and authentication

I am happily browsing the internet when I get disconnected. When I try to reconnect, I get told that I need a WEB password, and that my WPA2 is no longer acceptable.

This gets fixed if I:

uni set && wireless.radio0.disabled='1' && uci commit
&& uni set twireless.radio0.disabled='0' && uci commit

How can I resolve this?

Notice on the screesnshot that radio0 is ip as the problem presents itself.

(Currently connected to a different wifi SSID o a different router).

root@Confusion:/rwm/upper/lib/modules/4.19.65# cat /proc/version 
Linux version 4.19.65 (builder@buildhost) (gcc version 7.4.0 (OpenWrt GCC 7.4.0 r10750-7ec092e641)) #0 SMP Mon Aug 12 10:27:06 2019
root@Confusion:/rwm/upper/lib/modules/4.19.65# ls /lib/modules/4.1
4.14.131/  4.19.64/   4.19.65/   4.19.66/
root@Confusion:/rwm/upper/lib/modules/4.19.65# ls /lib/modules/4.19.6
4.19.64/  4.19.65/  4.19.66/
root@Confusion:/rwm/upper/lib/modules/4.19.65# cat /proc/cpuinfo 
processor	: 0
model name	: ARMv7 Processor rev 1 (v7l)
BogoMIPS	: 1600.00
Features	: half thumb fastmult vfp edsp neon vfpv3 tls vfpd32 
CPU implementer	: 0x41
CPU architecture: 7
CPU variant	: 0x4
CPU part	: 0xc09
CPU revision	: 1

processor	: 1
model name	: ARMv7 Processor rev 1 (v7l)
BogoMIPS	: 1600.00
Features	: half thumb fastmult vfp edsp neon vfpv3 tls vfpd32 
CPU implementer	: 0x41
CPU architecture: 7
CPU variant	: 0x4
CPU part	: 0xc09
CPU revision	: 1

Hardware	: Marvell Armada 380/385 (Device Tree)
Revision	: 0000
Serial		: 0000000000000000
root@Confusion:/rwm/upper/lib/modules/4.19.65# 
  • What model router are you using?
  • What version of OpenWrt are you using?

You didn't provide a screenshot.

I'm not sure how this information helps.

  • Not clear what a "WEB password" is
  • Can you screenshot this behavior?

Do you mean uci?

I am sorry; I blame autocorrect;

Yes, where is says UNI it should say UCI.
Where it says WEB it should say WEP.

And finally where it says screenshot attached, it should show an image of the Mac warning me that I was authenticated with WPA2 and that now the router wants WEP. It would also show that "wifi status" shows the radio UP and that I am using DFS Channels.

I'll repost the image next time the problem happens.

Please show us your /etc/config/wireless file - feel free to obscure things like MAC and keys.

root@Distraction:/etc/config# cat /etc/config/wireless 

config wifi-device 'radio0'
	option type 'mac80211'
	option channel '8'
	option path 'pci0000:00/0000:00:01.0/0000:01:00.0'
	option country 'DE'
	option legacy_rates '1'
	option hwmode '11g'
	option htmode 'HT40'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option mode 'ap'
	option ssid 'Distraction'
	option encryption 'psk2'
	option key 'Deleted'
	option network 'lan'

config wifi-device 'radio1'
	option type 'mac80211'
	option hwmode '11a'
	option path 'platform/10180000.wmac'
	option disabled '0'
	option channel '52'
	option htmode 'HT40'
	option country 'DE'
	option legacy_rates '1'

config wifi-iface
	option network 'wwan0'
	option ssid 'Confusion'
	option encryption 'psk2'
	option device 'radio1'
	option mode 'sta'
	option bssid 'AB:CD:EF'
	option key 'Deleted'

Try psk2+ccmp

The screenshot:

Be careful! One possibility is that you are connecting to a fake AP with the same SSID but WEP for encryption. WEP is weak.

Try if the following command can reveal if that's the case

iw dev wlan0 scan
1 Like

I though of that... I have not typed the password when on wep.
Also:

That first line, called 'Confusion' disappears when I shot down the router interface.

Not quite sure, but are you sure c2:55:27 is real mac address from your router device? It seems the "local bit" is set.

New data point; I renamed the wifi network, and after a while,

But I got something else; Everything was working dandy until I turned off the laptop (one of the devices connected to the network). At that point, everything stopped working.