Getting a timeout running hostapd_cli

I'm running the latest snapshot on a Belkin 3200 and not able to run hostapd_cli at all. Searched everywhere in the forum and web to no avail. I don't have wpad-mini installed (using wpad-openssl) and
I have also tried to add option ctrl_interface_group '0' to the config (which didn't work as it doesn't show on the hostapd-phy?.conf ) and it also didn't help.

#  hostapd_cli -i wlan1 ping
'PING' command timed out

What am I missing?

Thanks for the help!

I encountered the same problem on an RT3200. I believe it's caused by either ujail or seccomp. I fixed it by uninstalling procd-ujail and procd-seccomp and rebooting.

1 Like

Oh wow, that was it, just uninstalled uprocd-jail and it worked. Thanks, @mgorven !

1 Like

You can also delete /etc/capabilities/wpad.json to only disable ujail for hostapd.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.