Get no ip address from ISP

Hi, I am trying to use a Raspberry Pi4 with an additional USB network adapter as a router.
OpenWRT , USB network driver installed and the network config was modified. However, I do not get an IPv4 address from the provider.

Provider router is in bridge mode

Provider Germany Vodafone Kabel (Baden Württemberg)

Do you have any idea what this could be?
My current router (not from ISP) works fine.

You may need to clone the MAC address of the ISP device to the WAN interface of the OpenWRT device.

2 Likes

You may need to tag the frames to a specific vlan.

1 Like

Clone the WAN MAC address of the "old" router or reboot the cable modem.

1 Like

Thanks, after cloning the ISP MAC I see now an ip address on the interface.

But it starts with 10 and normally it should start with 80. Ping on IP or domain does not work as well.

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdae:d6e6:6fc4::/48'

config interface 'lan'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option device 'br-lan'
	option ipaddr '192.168.0.1'
	list dns '1.1.1.1'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0'

config interface 'WAN'
	option proto 'dhcp'
	option device 'eth1'
	option macaddr '11:22:33:44:55:66'
	option broadcast '1'

Contact your ISP and ask them if they have indeed allocated this private 10. address to you.

If the ISP device is still connected, and the OpenWRT device is behind that...DHCP, wireless, and the firewall on the ISP device should be turned off.

The OpenWRT router should be doing all of that.

The old ISP router is in bridge mode, everything like DHCP, WLAN and firewall is switched off.

Thanks, I called them, they gave me an 80 IP address.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

Problem unfortunately still exists ;(

What is the problem? You mentioned that you are not getting an IP and the last update is that you got an IP address.

Maybe I have described it wrong. I still get the wrong IP address.... It should start with 80 and I received a 10. My ISP provider also said that he has assigned me an 80.

What is the output of ifstatus WAN ?

Then you need to ask your ISP:

  • how the IP is allocated (usually by MAC address)
  • what error(s) the ISP can see see that's preventing it
1 Like

In bridge won't that create 2 devices for same macs on 1 ip?

No.

With DHCP, wireless, and the firewall turned off, the ISP device becomes just a modem.

The fact that your even getting an IP from the ISP shows the bridge is working.

They probably need to do something else on their end.

1 Like

Thanks for your help but I give up.... it's definitely related to OpenWRT and the setting...When I put my privately purchased HUAWEI WiFi AX3 router behind the modem, I get the IP address from the ISP and everything works.

As a test, try removing the cloned MAC address from the OpenWRT device, and set it up in the same configuration as the AX3 and ISP device.

I no longer understand the world... this morning I installed openWRT again on the PI4 and configured... now everything works.... I have made nothing different. :open_mouth:

thx everybody for help :slight_smile: