[general problem?] Linksys Wrt1200ac v2 wifi breaks up after moving unit

Hello, my router brings me to despair and since I'm still not sure if it is a hardware or software issue I thought I'd post here, maybe someone can help..

Ok, summary (I try to keep it short):

~ 1 year ago I bought a Linksys Wrt1200ac v2 router. Since the stock firmware lacked of many features like an ovpn server I quickly installed a custom firmware, dd-wrt, beta stadium then.
Everything worked alright but some things didn't, you could notice it's in beta (also the wifi worked without issues).
Now fast forward a few weeks ago and an update to a newer dd-wrt beta version I noticed that the wifi breaks up.

  • Ok, I instantly thought: well something with the software is messed up, since it's beta, ok.
    Router has 2 partitions, part_1 with stock firmware and part_2 where dd-wrt was.
    Now upon changing to part_1 and flashing LEDE to part_2 I noticed wifi still not working.
    Even worse: Changing to stock firmware, wifi is still not working.

So I think its a reception problem,...suddenly?!... Well the router is in an open tv shelf, I clear out my old xbox 360 and move my router forward.
Now suddenly wifi works again!....I move the unit again and wifi breaks up..

Alright so it has to be a hardware issue, I think. So no visual fault on the power supply+cord.
Well ok, now I think it's a loose soldered point somewhere and contact linksys and file RMA.

  • Meanwhile I ordered a brandnew router, same model from amazon as a transitional solution.
    Linksys told me I get a new unit and today I sent back the old one.
    Now, I set up my brand new router, flash LEDE and restore all settings. I didn't initially check the wifi with stock firmware...
    On this brand new router in LEDE AND in stock firmware I have the same wifi issues again. Moving router sometimes gets wifi to work...move it again -> wifi goes down.
    LEDE shows wifi is enabled and sometimes...not always the wifi light/symbol on the router also shows solid light...even when wifi isn't working.

Next I noticed: damn, I'm using the power supply from the old device because it was already set up behind the tv shelf perfectly. So I think it's the old power supply.
But these issues keep occuring with the new power supply as well.

  • I'm still thinking of all the changes I may have made that could have caused this issue.....

All I could think of were the lan cables I changed. A while back I fetched some supernumerary cat6 (rather short) cables from work and swapped them with others that where too long...
Right now I changed back to cat 5e cables except of one cable cause I ran out of cat 5e cables.

So, could wrong cables affect the wifi of a router????

Maybe someone can provide help here, any help is appreciated. :disappointed:

I would suspect signal interference.

See this article...

It just got stranger. After a time or accessing webif the new units power led starts blinking, nothing else.
I reflashed firmware and cleared the nvram / hard reset, Changed ethernet cables.
And placed it elsewhere (also plugging in to another socket). Leaving the router there it worked....
It normally is connected to a power strip, I now changed the socket of the power strip, maybe the one where it's plugged in is damaged. That's my last idea for now....
Even if there is signal distubance, that wouldn't be a reason why the whole system isn't working right?

I'm not sure what you mean by the "whole system not working".

I was addressing the WiFi issues.

If you connect to the router with an ethernet cable and cannot access the web, that's another issue.

Yeah now i also cannnot access the webinterface. Resettimg the router I somehow managed to flash the stock firmware, but after a while the device shuts itself of and restarts. Now if I access webif the same happens.
I assigned a static ip to my pc and i can ping the router ip but thats about it.
Linksys provides a tool to flash firmware this way but it says server not found.

Sounds like the router is trying to take a flash and not completing.

Try using TFTP to flash the router. There are tutorials on YouTube on how to use it.

If that doesn't work, you may need to follow these instructions to unbrick it...

Yeah, thats the tool I tried. On pc I can ping the router but if I hit upgrade in TFTP it says "..server ( not found.."

Yesterday I also found that video and ordered such cable.
Seems like I have to do it this way.
I hope there isn't something else messed up, like on other partitions or so...

What I still don't understand: we're talking about a new unit. What i did is flashing david's custom lede build (maybe this isn't compatible with V2 routers..) and restore lede settings from the old router.
I could enter lede webif on old router and set it up w/o problems at first so I assume the lede build is compatible...
Could restore "faulty" lede settings cause a router to brick?

Alright, I followed these instructions and flashed stock firmware to both partitions, output was fine, flash successful.
Unfortunately this didn't solve my problem. After a while the router switches off and back on and power led keeps blinking.
I looked at the partitions of my router at https://wiki.openwrt.org/toh/linksys/wrt1x00ac_series#armada_385
Since the firmware flash was successful I'll rule out that the 2 firmware partitons have a problem.

Even after firmware flashes there are settings which persist, are they stored in this mtd8/syscfg partition?
Is this partition maybe corrupted? If so do you know how to fix it?
Other than that there's mtd0 with the bootloader on it.
And these partitions: mtd1/u_env, mtd2/s_env, mtd3/devinfo.
I also did reset the bootloader environment with these commands in Marvell prompt:
env default -a
without success.

I can't imagine how the bootloader got corrupt but right now that's my last line.
I found this: https://github.com/nitroshift/wrt1900ac-v1-Mamba-bootloader-recovery-files/wiki

I'll try to recover the bootloader and report back.

Or does anyone have other ideas?