Gateworks Ventana 5410 sysugrade and reboot

On a sysupgrade it all seems to go, ie it writes properly to flash, however the reboot fails and halts the cpu.

If this can be fixed I will offer a bounty of a GW-5410, oem with no video, etc and include 4 NX200 radio cards. I will pay shipping. So, if someone wants a spare toy and has some knowledge and time ...

I am currently stuck at the Lede 17.xx because it works. I would truly like to have the new 19.07.xx series. The GUI is short of fabulous.

Note I have followed GW literature and made sure that the gsc module is loaded. It actually seemed to be included by choosing the GW series in menuconfig.

I've encountered this in the past on that board.
A fix was pushed upstream but only worked on the gw52xx for now iirc.

It's due to a reset property in DT which is not known for this board model.
If I ever have some time, I'll try to fix it. (no promises)

Thanks.

If you ever find the time I would be willing to compensate you, for my own good and of the community. I think it is terrible that such a fine board cannot be properly upgraded.

One thing I will point out, is that Lede 17.01 works, so it probably documents the reset property for someone who knows about that stuff.

If I'm understanding this correctly, should I be able to sysupgrade then on the GW52xx? I attempted flashing 19.07.xx directly but am having issues detecting my mini PCI-e wifi module (WLE900VX-I).

What kind of issues exactly?

I have a few GW52xx running here at the moment with 19.07 and wifi cards attached.
Just make sure you use the PCIe slot on the left for native PCIe devices (marked with J8, closest slot to the battery)

After flashing I ran a wifi config > /etc/config/wireless since there is no wireless config already made, but I'm still not getting it to show up. I'm about to switch slots and run a dmesg.

Edit: Should mention that I couldn't lspci either. In dmesg I'm seeing "PCI Bridge configuration invalid".

This is not an error or warning.
It's an info message saying that the current bridge will be reconfigured.

Are you running 19.07 as a result of upgrading from LEDE 17.01? The only success I've had so far is working with the GW OpenWRT 16.02 BSP.

I have tried 18.0x and 19.0x (many different versions and at various times) and none of them will sysupgrade and reboot. The sysupgrade writes the flash properly but then the processor is halted.

17.0x all work just fine and nobody is able to fix the new versions. I, personally have no idea where to look or I would begin to compare 17 to 19 and look for code changes or, most likely, code not included. It will most likely be only a couple of lines, but they are trees in the forest to someone like myself.

So, it seems that something was not brought along from 17.0x to the new versions.

I like what I see in the 19.0x stuff and would love to move forward, but an upgrade that halts the cpu and requires a physical power-off/power-on is pretty much a deal breaker.

No,
I flashed 19.07 natively (custom build) using jtag
Works like a charm.

Can you show a full bootlog?

@lonnie

I'll check asap, but it can take some time as it's low prio at work.

Update:
here is the reboot issue reason

via GW upstream build? Or completely custom? I'll try to get that bootlog when I have the opportunity.

fully custom.
No gateworks bsp