Full bridge mode > PPPoE discovery fail VDSL

"Timeout waiting for PADO packets"

Modem (to be in full bridge) ==> Asus router doing ppp authentication

Problem is the asus is showing the above error and cannot initialize the pppoe connection.
Strange thing is if I use another non openwrt modem in bridge to establish the session first then swap the modem putting the openwrt back in place the internet continues to work unless anything is switched off for an extended period.

Here is my config on the openwrt based modem, what should I change

Config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'none'
option default_ps '0'

config device 'wanptm0'
option name 'wanptm0'
option macaddr '10:13:31:xx:xx:xx'
option ipv6 '0'

config interface 'wan'
option macaddr '10:13:31:xx:xx:xx'
option ifname 'ptm0'

config config 'config'
option wan_mode 'bridge'

config interface 'lan'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '64'
option force_link '0'
option ipv6 '0'
option pppoerelay 'ptm0'
list ifname 'eth0'
list ifname 'eth1'
list ifname 'eth2'
list ifname 'eth3'
list ifname 'eth5'
list ifname 'ptm0'

config switch 'bcmsw'
option reset '1'
option enable_vlan '0'
option qosimppauseenable '0'
option jumbo '0'

What is it for an VDSL Modem ?
Which OS (iclusive version) ?

Technicolor dga4130 its got some version of openwrt on it

You might take a look at this thread...

However, in a bridge situation (router > modem > Internet), the modem should not be doing anything with PPPoE, wireless, or anything else.

That is now the job of the router.

Also keep in mind that most VDSL ISPs do require some kind of vlan tagging, without it the ppp connection won't succeed in this manner.

which firmware is running on the asus router ?
and what type of dsl connection are we talking about (ADSL, VDSL) ?

problem is not vlan related if he is able to establish a connection...

It is a VDSL connection, no vlan requirement from my ISP.

RMerlins firmware