Fujitsu Futro S920 - Help with troubleshooting stability/reboot issues

i will try to plug in a smaller NIC, but this still barely explain why with 4 USB Nics everything is stable under heavy load, while with just 1 port in use of the quad NIC it dies after a few kb of traffic. Again this really sound like a factory defect or bug with this specific revision since it's been replicated by three people and one of these claims that all other revisions works well with quad NICs.

I ordered from ebay a 1.5GHz revision to prove/disprove this and guess what? the Ebay seller made a mistake and sent me a 2.2 GHZ version again which has the same exact issue. I am currently in the process of returning the item and hopefully get the right one.

In the meantime i suppose i could try a 2 NIC Card i have lying here to see if it works or reboots again. I'm not too happy about it because it means wiping back from the start pfsense since if you remove a NIC it gets upset and doesn't complete the boot. That is throwing away half a day of configurations but at this point it's just science.

@ITXProtocol Checking is pretty easy, you put your multimeter on DC mode under 20(some might have 60) value and place the black tip on a un-varnished metal part of the thin client (mass), while the red one one pin of the riser. You do this for each pin being carefull not to touch two or more pins a the same time to avoid short-circuits and if any has the 12v reading on the multimeter (could be 11.9 or some similar value) it means the socket is providing current and plugging a power source there might not be a good idea.

If the pins all reads 0 it might be as the vendor said and my riser is different from yours.

let us know what happens with the single nic card. Again i don't think age is the issue, BSD has been having support for this cards since forever. I am fairly sure that if you plug yours on a regular PC it will work like a charme like mine does.

1 Like

Morning guys,

@Pico I personally have no knowledge of SQM other than this link i read through. If it doesn't come with OpenWrt by default, chances are i have not used it.

@fumareddu i ended up buying a TP-Link TG-3468 1 Port NIC

I did some IPerf3 testing on all my network cards in another PC. They all achieved near gigabit speeds (intels were ~900mbps, realtek was ~800mbps), results can be found here, so they all seem to be working as intended.

When the time came to try the TP-Link card in the Fujitsu S920, i found out that i have Version 4 of this network card. Looking through TP-Link's website, turns out only V1 has Linux drivers...

I'm not sure how @geo999 has used the same card, i would guess they have V1 or a special trick up their sleve :slight_smile: Seems like the drivers were already present in OpenWrt since the integrated NIC looks to use the same RealTek chipset.

Since i had that 2 port Intel E1G42ET card i just bought, I've put that in my S920 instead. Good news is that i am not getting weird "clearing RX timestamp" messages, nor has the device rebooted when browsing the GUI or when being put under load, unlike my older 2 port & 4 port NICs, so it seems that a newer 2 port NIC will not cause issue?

One thing to note is that the results yielded a lower IPerf3 score of 810Mbps download & upload (purely RJ-45 to RJ-45, no USB NICs involved) & would fluctuate from 500Mbps-850Mbps.

@fumareddu I did check the PCIe riser's 4-pin connector & it would seem as though one of the pins does supply 12V... in fact, you were bang on, with 11.94V.

So taking away from my testing:

  1. My modern 2 port works better than my old 2 port.
  2. My PCIe riser does look supply 12v rather than take 12v.
  3. Check very carefully about what version of an NIC you buy.

here is what "lspci -v" reports for my two cards, tp-link TG-3468 and the embedded one:
And it looks like the same r8169 driver is used in both cases.

01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15)
        Subsystem: Realtek Semiconductor Co., Ltd. **TP-Link TG-3468 v4.0** Gigabit PCI Express Network Adapter
        Flags: bus master, fast devsel, latency 0, IRQ 24
        I/O ports at e000 [size=256]
        Memory at fea04000 (64-bit, non-prefetchable) [size=4K]
        Memory at fea00000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [40] Power Management version 3
        Capabilities: [50] MSI: Enable- Count=1/1 Maskable- 64bit+
        Capabilities: [70] Express Endpoint, MSI 01
        Capabilities: [b0] MSI-X: Enable+ Count=4 Masked-
        Capabilities: [d0] Vital Product Data
        Capabilities: [100] Advanced Error Reporting
        Capabilities: [140] Virtual Channel
        Capabilities: [160] Device Serial Number 01-00-00-00-68-4c-e0-00
        Capabilities: [170] Latency Tolerance Reporting
        Capabilities: [178] L1 PM Substates
        **Kernel driver in use: r8169**

02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 0c)
        Subsystem: **Fujitsu Technology Solution**s Device 11ff
        Flags: bus master, fast devsel, latency 0, IRQ 33
        I/O ports at d000 [size=256]
        Memory at fe900000 (64-bit, non-prefetchable) [size=4K]
        Memory at fc800000 (64-bit, prefetchable) [size=16K]
        Capabilities: [40] Power Management version 3
        Capabilities: [50] MSI: Enable- Count=1/1 Maskable- 64bit+
        Capabilities: [70] Express Endpoint, MSI 01
        Capabilities: [b0] MSI-X: Enable+ Count=4 Masked-
        Capabilities: [d0] Vital Product Data
        Capabilities: [100] Advanced Error Reporting
        Capabilities: [140] Virtual Channel
        Capabilities: [160] Device Serial Number 00-00-00-00-00-00-00-00
        Capabilities: [170] Latency Tolerance Reporting
        **Kernel driver in use: r8169**
1 Like

Evening @geo999 ,

Thanks for the driver & CLI output. I'll double-check my router config & see if that driver is installed.

It's rather odd since if the driver for the onboard LAN & the TP-Link is the same, then why would the onboard LAN work, but the card not? even with a newly flashed OpenWrt build.

I'll do some testing & update the thread.

Evening Guys,

Apologies for my delay in updates.

@geo999 I discovered that the TP-Link TG-3468 NIC (PCIe 1x) does not like my PCIe 4x riser. When connected with the riser, the card does not look like it comes to life at all. My Intel E1G42ET is also PCIe 1x but works fine with the 4x riser. I ended up trying the NIC directly connected to a different PC, which reveals that the NIC works fine when connected directly to a 1x slot. Next, I tried taking out the whole motherboard & directly connecting the TP-Link TG-3468 card to the motherboard & it works fine when directly connected. IPerf3 results can be found here.

the results are better than i expected, in the 800mbps-900mbps range which facilitates my requirements of 150mbps/150mbps WAN connection.

Thank you for the help in troubleshooting this issue.

In the future, i might purchase the quad-core CPU variant of the S920, as shown in the video. If so, i may make a new thread detailing the results/compatibility of using my current NICs.

what kind of PCIe reiser do you use ?


This is the PCIe riser I use.

Hey sorry for the late reply, but i managed to snag a week away from work.

Finally i managed to get my hands on a quad core version of the thin client and immediatly tried it with the used Intel Quad NIC that kept resetting the dual core version.

As i thought it works flawlessy under heavy load, with all 4 ports used. This basically confirm that whatever the issue is, was tied to some specific hardware shenanigans on the dual core revision of the thin client. It's also a lot cooler due to the frequency being lower i guess, the other was skyrocketing to 80C without a fan onto it, while this sits at around 49-55C.

At this point i may try a newer dual nic on the dual core version just so i can use it on some other appliance which requires less LANs and if i do, i will report the results here, but as a general advice i would just say to avoid the other two versions and stick to the smaller one.

HF guys!


I got the same one, and yes, this one does not work as it should.
The problem with it is that pin 10 on the B side of the PCIe slot marked as 3.3V AUX is not connected by this reiser, thus the TP-link TG-3468 is not powered on.
The fix is to solder a wire from PCIe slot on the board to the PCIe slot on the reiser to get the power to the card.
My guess is that other cards work because they do not use this power pin.

1 Like

Hey, i just tried a new cheap random manufacturer 2 port nic on the 2.2 GHz version and it works perfectly, with two different risers.

What you're saying is strange considering OP tried to disassemble the client and connect the NIC directly onto the motherboard without the Riser and got the same result. Also i did have a different riser and got the same exact result, so unless all riser are affected by this issue i really find it strange, also keep in mind that the same NICs that weren't working in the 2.2 GHz version worked fine with the 1.5 GHz version with the same riser for me. So again: not a riser problem but an hardware issue onto the motherboard of the 2.2 ghz revision.

I would just stay away from the 2.2 ghz version at this point

feel free to post the brand or product link of that card.
if someone buys the wrong version of the S920, a working NIC would make life easier.

Morning Guys,

Just to provide some clarification from my side, my TP-Link TG3468 is the only NIC that has issues with my PCIe rissr. My Intel E1G42ET is also PCIe 1x, like my TP-Link NIC, except it works fine with the riser. My 2 older server cards (linked higher up this thread) are both PCIe 4x & work fine with this riser, taking into account the instability issues they have with this particular model of S920.

The TP-Link NIC I have is Version 4, same as @geo999 & works fine when directly connected to the PCIe slot on the motherboard. Based on all the troubleshooting we have done in this post, both the Intel E1G42ET & TP-Link TG-3468 NICs will work on my model of S920, with my testing being an iperf3 at 850-920mbps for 2 minutes.

I believe that @geo999 is onto something with the power PCIe pins. My theory is that the TP-link NIC is using a different pin for power, since 3 NICs work without issue. As a control, all NICs were plugged into a completely different PC, where all powered up & endured my 2 minute iperf3 test without issue.

If you'd like me to do any further testing feel free to suggest ideas.

i would check the nic spec to have very low power consumption
eg. Intel 82571EB

this is the one. It doesn't even have a brand (i mean at least i never heard ULANSEN) but i kept it running with 4k videos the whole day and launched speedtests everynow and then and it never rebooted.

That being said i still think the 2.2 Ghz version runs way too hot for this particular use. I have had to use a fan (which you can connect to a PWM socket located below the CPU heat sink). But since the space it is what it is i had to get a 40X20 fan and zip tie it between the heatsink and the PCI-e slot to keep it in place. This way the CPU was stable at 50C which is fine, otherwise i went up to 80 with minimum load so... do it at your own risk.

i cannot do any more test on the 2.2 ghz version because i gave it away to a colleague of mine who needed a toy to play with with pfsense and since he didn't need the quad port but was fine with the dual i just gave it to him.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.