FTTH unable to complete PPPoE Discovery

Hi

My ISP is providing FTTH, there's a Fiber NT (ONT) from which an ethernet cable enters my home.
According to the ISP, any router can be used, as long as it meets 3 basic requirements:

  1. be able to build up a PPP connection,
  2. support VLAN 10 tagging,
  3. have Gigabit Ethernet ports

I currently have a Linksys WRT32X with OpenWRT 19.07.6 installed.

This is my network config:

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd5a:f0c8:c049::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option proto 'pppoe'
	option username '***'
	option password '***'
	option ifname 'eth1.10'

config interface 'wan6'
	option proto 'dhcpv6'
	option ifname 'eth1.10'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 3 5t'
	option vid '1'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option vid '10'
	option ports '4t 6t'

I have plugged the ethernet cable coming from the Fiber NT into the router WAN port.

I've tried to change option ports '4t 6t' in switch_vlan 2 to option ports '4 6t'.
I've also tried disabling IPv6 and disconnecting the wan6 from the switch_vlan 2 (by removing option ifname 'eth1.10').

Nothing seems to work, and I always get the following errors in the log:

Sun Mar  7 13:11:08 2021 kern.info kernel: [  949.474852] mvneta f1070000.ethernet eth1: configuring for fixed/rgmii-id link mode
Sun Mar  7 13:11:08 2021 kern.info kernel: [  949.482640] IPv6: ADDRCONF(NETDEV_UP): eth1: link is not ready
Sun Mar  7 13:11:08 2021 kern.info kernel: [  949.488532] mvneta f1070000.ethernet eth1: Link is Up - 1Gbps/Full - flow control off
Sun Mar  7 13:11:08 2021 daemon.notice netifd: Interface 'wan' is enabled
Sun Mar  7 13:11:08 2021 daemon.notice netifd: Interface 'wan' is setting up now
Sun Mar  7 13:11:08 2021 kern.info kernel: [  949.499429] IPv6: ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready
Sun Mar  7 13:11:08 2021 daemon.err insmod: module is already loaded - slhc
Sun Mar  7 13:11:08 2021 daemon.err insmod: module is already loaded - ppp_generic
Sun Mar  7 13:11:08 2021 daemon.err insmod: module is already loaded - pppox
Sun Mar  7 13:11:08 2021 daemon.err insmod: module is already loaded - pppoe
Sun Mar  7 13:11:08 2021 daemon.info pppd[7109]: Plugin rp-pppoe.so loaded.
Sun Mar  7 13:11:08 2021 daemon.info pppd[7109]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.7
Sun Mar  7 13:11:08 2021 daemon.notice pppd[7109]: pppd 2.4.7 started by root, uid 0
Sun Mar  7 13:11:09 2021 daemon.debug pppd[7109]: Send PPPOE Discovery V1T1 PADI session 0x0 length 12
Sun Mar  7 13:11:09 2021 daemon.debug pppd[7109]:  dst ff:ff:ff:ff:ff:ff  src 60:38:e0:c2:bf:38
Sun Mar  7 13:11:09 2021 daemon.debug pppd[7109]:  [service-name] [host-uniq  c5 1b 00 00]
Sun Mar  7 13:11:14 2021 daemon.debug pppd[7109]: Send PPPOE Discovery V1T1 PADI session 0x0 length 12
Sun Mar  7 13:11:14 2021 daemon.debug pppd[7109]:  dst ff:ff:ff:ff:ff:ff  src 60:38:e0:c2:bf:38
Sun Mar  7 13:11:14 2021 daemon.debug pppd[7109]:  [service-name] [host-uniq  c5 1b 00 00]
Sun Mar  7 13:11:19 2021 daemon.debug pppd[7109]: Send PPPOE Discovery V1T1 PADI session 0x0 length 12
Sun Mar  7 13:11:19 2021 daemon.debug pppd[7109]:  dst ff:ff:ff:ff:ff:ff  src 60:38:e0:c2:bf:38
Sun Mar  7 13:11:19 2021 daemon.debug pppd[7109]:  [service-name] [host-uniq  c5 1b 00 00]
Sun Mar  7 13:11:24 2021 daemon.warn pppd[7109]: Timeout waiting for PADO packets
Sun Mar  7 13:11:24 2021 daemon.err pppd[7109]: Unable to complete PPPoE Discovery
Sun Mar  7 13:11:24 2021 daemon.info pppd[7109]: Exit.
Sun Mar  7 13:11:24 2021 daemon.notice netifd: Interface 'wan' is now down
Sun Mar  7 13:11:24 2021 kern.info kernel: [  964.763904] mvneta f1070000.ethernet eth1: Link is Down
Sun Mar  7 13:11:24 2021 daemon.notice netifd: Interface 'wan' is disabled

Does anyone have any idea as to wether I'm doing something wrong, or what else I could try? Or could this be a fault on the ISP side, e.g. the line didn't get activated or they activated the wrong one?

~ Thanks

This might be a daft question - if so, please forgive me; I'm not familiar with the WRT32X - but one thing which catches my eye is the switch configuration. You've got both 5t and 6t enumerated; does the kernel expose both virtual ports 5 and 6?

As an example, here's the config exerpt from my device:

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0 6t'

On this device, VLAN 1 is the LAN and VLAN 2 is the WAN. Ports 1-4 are the LAN ports and 6t is the hook into the kernel. Port 0 is the WAN port and 6t is the hook into the kernel.

As I'm not familiar with the WRT32X I'm not going to categorically state that your WAN VLAN configuration (i.e. port numbers) is incorrect, but it's not what I'm accustomed to seeing.

Check out this thread

1 Like
config switch_vlan
	option device 'switch0'
	option vlan '10'
	option vid '10'
	option ports '4t 6t'

Forgot to make the Switch see WAN as VLAN 10 instead of 2.

3 Likes

@iplaywithtoys I'm not 100% following, not really a networking expert, but I'm going to guess "yes", because in the default config (after a clean install of OpenWRT) the virtual port 5 is also in the config.

Default network config:

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fde2:3015:4e4b::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option ifname 'eth1.2'
	option proto 'dhcp'

config interface 'wan6'
	option ifname 'eth1.2'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 3 5t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '4 6t'

This is the default config as shown in LuCI

In the OpenWRT wiki port 5 is also mentioned

@frollic I just checked out the thread. Tried adding a LAN port to the vlan and used eth0.10 (instead of eth1.10) for wan. Unfortunately the issue persists.

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fde2:3015:4e4b::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth1.1'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option ifname 'eth0.10'
	option proto 'pppoe'
	option password '***'
	option ipv6 'auto'
	option username '***'

config interface 'wan6'
	option proto 'dhcpv6'
	option ifname 'eth0.10'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option vid '1'
	option ports '1 2 3 6t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option vid '10'
	option ports '0t 4 5t'
1 Like

@lleachii thanks for the suggestion, just tried this, but alas no change.

I've also just tried plugging the uplink directly into my computer and set up PPPoE, but it constantly gives the error that it can't find a PPPoE server.

Will try customer support on Monday probably.

1 Like

I assume you setup the VLAN on the test machine too?

1 Like

I tried, but have only access to a Mac at the moment, and when creating a PPPoE service from a VLAN it won't let me enter credentials. Thanks for the suggestions

This might sound a bit Heath Robinson, but might it be worth trying a VM with a bridged interface for the guest? Depending on the VM software, the Mac host network, and the guest capabilities, you might be able to implement VLAN tags for this sort of testing.

Some people reported their ONT was using untagged packets, even though the ISP said they should be tagged. So you could try that, just set port 4 to untagged in the switch.

wan6 connected to eth1 should be removed, as IPv6 on pppoe doesn't work that way. You would attach the IPv6 wan to the output of the pppoe bridge, which is @wan.

A Linux PC (bare metal) would be ideal for testing since you can see VLAN tags with Wireshark. I don't know if MacOS supports VLAN tagging or not. Windows does not.

2 Likes

Depends on the NIC and driver:

2 Likes

What worked for me is:

(I have WRT3200ACM, with VLAN 35 as my ISP's PPPOE VLAN)

Note: And ofc, the WAN/WAN6 interface is eth1.10

2 Likes

The correct config turned out to be (as @dominick-han suggested) :

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option ifname 'eth1.10'
	option proto 'pppoe'
	option password '***'
	option username '***'
	option ipv6 'auto'

config interface 'wan6'
	option proto 'dhcpv6'
	option reqaddress 'try'
	option reqprefix 'auto'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option vid '1'
	option ports '0 1 2 3 5t'

config switch_vlan
	option device 'switch0'
	option vlan '10'
	option vid '10'
	option ports '4t 6t'

But more importantly ... the ethernet cable protruding from the wall was the wrong one, the previous owner of the apartment cut the uplink off at the wall, so had to lay some new cable, so simple, so stupid

Thanks all :sweat_smile:

2 Likes

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.