Frustrated Noob

I am currently attempting to migrate from DD-WRT for increased security but am quite frustrated. I am using a Linksys WRT1900ACv1 and a Arris DOCSIS 3.0 modem with a connection to Comcast. I've searched through the forum and on YouTube but can't find a solution to my problem.

I have successfully flashed OpenWRT to the router and the devices on my WiFi network connect successfully and communicate with each other. My problem is that for the life of me I cannot get the router to connect to Comcast and pull a public IP number. Below are screenshots from my WAN interface (Sorry for this but I don't know any other way to get my problem stated):

What am I overlooking? TIA!

reboot modem, MAC issue?

1 Like

I have rebooted the modem as well as rebooting the modem with the coax cable disconnectecd

Post link output from:

cat /etc/os-release /etc/config/network /etc/config/dhcp | nc termbin.com 9999

to see if anything can be spotted.

1 Like

Does it require a VLAN?

There could be many reasons why you would want to run OpenWRT but the above is not realy a valid one. (DDWRT is using K6.1 and packages are up to date)

That said power off modem and router wait 5 min. Power on modem and after 5 minutes power on the router.

If it were the cable company refusing to serve your MAC, there would still be some Tx packets reported on wan-- unsuccessful DHCP requests. The fact that the packet count stays at 0 suggests that the port is not up at all. Do the "port status" icons on the main status page show that wan is up? There should also be a log entry whenever the Ethernet cable is unplugged or re-plugged.

I don't think that Comcast has any special concerns or waiting time should you change your router. Changing the modem does require registering the new modem to your account.

There is typically some chill period before you can change MAC address at your line, just call provider say you got new router and cannot connect. They will clear CPE and off you go. Or wait day to week.

1 Like

Hi

I run a similar setup (comcast, wrt1900acsv2 on 6.1.82)

The default DSA configuration on the WRT's changes the MAC address on the WAN interface, so Comcast won't give you an IP address unless you power down.

When I switch routers (RPi4 or x86_64), I need to power down the everything for at few minutes.

Power up the router, go to the overview page/network.

Power up the modem, you should get an WAN ip address of 192.168.100.1 in a minute.
About 2 minutes later, you should get an IPv4 address.
Another 2-3 minutes later, you should get an IPv6 delegation.

2 Likes

More accurately 5 years ago ddwrt nagged you into cloning mac address of pc you used then, now original address is returned to router.

Your br-lan and wan MAC addresses are the same. You’ve configured this incorrectly. Easiest thing to do is a full reset of the router. System > Backup / Flash Firmware > Perform reset.

From there don’t mess with anything other than selecting DHCP client for WAN.

Also, Use broadcast flag isn’t required with Comcast.

Edit:
More specifically you’ve configured your interfaces incorrectly. br-lan and wan should have different MAC addresses. Without more info I can only assume that you bridged your wan port and br-lan ports, which is not the default setup. I can’t say what else might be wrong given that you also unnecessarily checked the Use broadcast flag, hence the suggesting to start over and take it slow.

No such limitation on mac addresses.

Thanks to everyone that replied to my plea for help. I got it working and here's the steps that I used:

  1. Unplug and disconnect coax on the modem
  2. Replace the router with new one flashed with OpenWRT
  3. Turn on the router and get a LAN IP on the laptop.
  4. Reset the OpenWRT on the router to defaults
  5. Get a new LAN IP on the laptop
  6. After the modem has been disconnected for 30 minutes, reconnect coax and power
  7. Voila! It works!

Thanks again!

1 Like

Welcome to OpenWrt! I'm glad you're on the air. Two suggestions:

  1. Since you solved the problem, consider clicking the checkbox at the bottom of your recent post. That automatically marks this post as the solution, as an aid to people who're looking for answers.

  2. Consider changing the topic from "Frustrated Noob" to something that describes the problem. (I would probably say something like, "Trouble with OpenWrt and Comcast modem".) That, again, helps people in a similar situation find answers. To do this, click the pencil to the right of the topic.

Please get back to me if you have questions. Thanks!

6 Likes

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.