Fritzbox 7530 and RFC4638 (Baby Jumbo Frames)

config interface 'wan'
	option proto 'pppoe'
	option device 'eth0'
...
	option mtu '1500'

config device
	option name 'eth0'
	option mtu '1600'

Guess what? Just like I said, only 'device' is applied. MTU for pppoe-wan was set to the value received from ISP. You're plainly wrong.

I didn't get the point.

  • Set PPPoE on the Interface in the Interface config/tab.
    *Set raw Ethernet MTU on Device page/config - this was explained many posts ago
  • You disagree you need to set 2, cool
  • 1500 is a Global defult
  • This is a moot discussion if you don't wanna discuss editing yours
  • Did you do a full network restart?
  • I provided a screenshot and the config

You can't explain what MTU in pppoe-wan section does. That's the problem. I see it as a bug.

I edited just like you said... but you config fail to make expected results...

Because you have PPPoE and I thought you explained, if not, please don't play gotcha games and ask moot questions:

:point_up:
I assume this is the section. But you provided the information.

Feel free to simply clarify instead of being accusatory (e.g. full configs, explaining where the x -8 occurs, etc.).

I'm not playing games. I'm just saying that your recipe doesn't work for me. Which implies that your explanations has some faults.

Hi there, thanks for replying, as @lleachii mentions, the Fritzbox 7530 has a dsl0 interface and doesn't use an ethernet one. Sounds like MTU settings for dsl0 are set to the default 1500 as @pythonic says. For reference here is my ip link output (with dsl0 set to 1508 MTU in config):

(Note that eth0 is an interface that bridges traffic from the LAN switch to the CPU, it's not used for DSL)

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP qlen 1000
    link/ether 3c:a6:2f:09:cc:b8 brd ff:ff:ff:ff:ff:ff
3: lan1@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP qlen 1000
    link/ether 3c:a6:2f:09:cc:b8 brd ff:ff:ff:ff:ff:ff
4: lan2@eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue master br-lan state LOWERLAYERDOWN qlen 1000
    link/ether 3c:a6:2f:09:cc:b8 brd ff:ff:ff:ff:ff:ff
5: lan3@eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue master br-lan state LOWERLAYERDOWN qlen 1000
    link/ether 3c:a6:2f:09:cc:b8 brd ff:ff:ff:ff:ff:ff
6: lan4@eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue master br-lan state LOWERLAYERDOWN qlen 1000
    link/ether 3c:a6:2f:09:cc:b8 brd ff:ff:ff:ff:ff:ff
7: wlan0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether 3c:a6:2f:09:cc:ba brd ff:ff:ff:ff:ff:ff
8: wlan1: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether 3c:a6:2f:09:cc:bb brd ff:ff:ff:ff:ff:ff
9: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether 3c:a6:2f:09:cc:b8 brd ff:ff:ff:ff:ff:ff
10: dsl0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP qlen 1000
    link/ether 84:a4:23:06:4f:fb brd ff:ff:ff:ff:ff:ff
11: dsl0.101@dsl0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether 84:a4:23:06:4f:fb brd ff:ff:ff:ff:ff:ff
12: pppoe-wan: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1492 qdisc fq_codel state UNKNOWN qlen 3
    link/ppp

Thanks

Jon

1 Like

Thanks for this, this would explain what I am seeing and would also explain why it works on my old BT Homehub which is xrx200. Out of interest, where in the code are you seeing this?

Thanks

Jon

We moved on from this (BTW, this settings are totally legit). I used what you said - 1600 MTU for eth0 and 1500 for pppoe-wan working over it. But pppoe-wan was set to the value received from ISP. The only way to change pppoe-wan MTU is to set in Device tab (or section of /etc/config/network).

Can't wait to receive your technical reply...

Hi there, sorry missed your reply in all the posts. Yes I already do this, it sounds like the issue may be with the dsl driver being hardcoded to 1500 bytes. Thanks for replying though.

We did not, I'm quite sure you just asked me what the config interface section was for, and I replied - I assumed pppoe-wan. You told me no (I now understand your point, but I did answer you, it caused me quite the confusion since it was already established you had PPPoE and I did not).

Anyways, I tested:

config interface 'test' 
        option proto 'pppoe'      
        option device 'wan'                    
        option ipv6 'auto'
        option mtu '1508'
        option username 'idoonthavePPPoE'
        option password 'timurshouldknow'

config device
	option name 'wan'
	option mtu '1508'

root@OpenWrt:~# ifconfig wan
wan       Link encap:Ethernet  HWaddr xx:xx:xx:xx:xx:xx  
          UP BROADCAST MULTICAST  MTU:1508  Metric:1
          RX packets:38372827 errors:29 dropped:4 overruns:0 frame:0
          TX packets:24074984 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:34007618391 (31.6 GiB)  TX bytes:9481912117 (8.8 GiB)
          Interrupt:20

Since I don't have PPPoE, I didn't have Internet, hence no connection hence I cannot see my PPPoE MTU. You would have that information, I can't guess it. So I can't be reasonably told I'm wrong. I assume the ISP set it or it subtracted 8. Feel free to clearly state. You stated:

If this is occurring for you, my apologies, I missed it. And since I don't have PPPoE I can't test it. If something other than x - 8 is occurring, just tell us. Also, I cant guess if your ISP is setting the MTU, again, I discussed the Ethernet device, which you screenshot the interface page to inquire about PPPoE I don't have. It's clear your configs aren't working or you insist I find a PPPoE connection to share my results.

Feel free to tell us, make a report or not.

Thank you for finally explaining. I already noted that MTU's must be set on that tab. My apologies if I didn't make that clear. Yes, since only you see and experience the PPPoE, I cannot say.

It seems you're noting 3 locations to set MTU (2 for PPPoE and 1 for raw Ethernet). I wholeheartedly agree one is incorrect if that's the case.

:laughing: but which of those two identical settings worked? Was it the first one or the second?

We're going back in circles. I said my PPPoE connection never established, I don't have PPPoE.

So we can only be discussing the raw Ethernet connection.

This is why I asked you to clarify at this point.

Then why did you reply it if you can't test it? Looks like I specified it from very beginning (just like OP) that we are talking about PPPoE.

I can't help that you don't understand.

If I'm the one that missed it, very well. Good healthy discussion nonetheless. Good day.

What forbids you to set up pppoe connection (even if your ISP doesn't support it) and see it for yourself?

I do understand. What you don't understand is that I'm talking about THE SAME pppoe-wan interface which has two ways to override MTU. TWO. And one of those doesn't work. I'm not talking about Ethernet.

???

I just did, I showed the config.


here's more:

Wed Dec 20 09:14:56 2023 daemon.err pppd[10166]: Unable to complete PPPoE Discovery
Wed Dec 20 09:14:56 2023 daemon.info pppd[10166]: Exit.
Wed Dec 20 09:14:56 2023 daemon.notice netifd: Interface 'test' is now down
Wed Dec 20 09:14:56 2023 daemon.notice netifd: Interface 'test' is setting up now
Wed Dec 20 09:14:56 2023 daemon.info pppd[10645]: Plugin pppoe.so loaded.
Wed Dec 20 09:14:56 2023 daemon.info pppd[10645]: PPPoE plugin from pppd 2.4.9
Wed Dec 20 09:14:57 2023 daemon.notice pppd[10645]: pppd 2.4.9 started by root, uid 0

Wed Dec 20 09:15:12 2023 daemon.warn pppd[10645]: Timeout waiting for PADO packets
Wed Dec 20 09:15:12 2023 daemon.err pppd[10645]: Unable to complete PPPoE Discovery
Wed Dec 20 09:15:12 2023 daemon.info pppd[10645]: Exit.
Wed Dec 20 09:15:12 2023 daemon.notice netifd: Interface 'test' is now down
Wed Dec 20 09:15:12 2023 daemon.notice netifd: Interface 'test' is setting up now
Wed Dec 20 09:15:12 2023 daemon.info pppd[11511]: Plugin pppoe.so loaded.
Wed Dec 20 09:15:12 2023 daemon.info pppd[11511]: PPPoE plugin from pppd 2.4.9
root@OpenWrt:~# ifconfig pppoe-wan
ifconfig: pppoe-wan: error fetching interface information: Device not found

I attempted to test, apologies again. Can't satisfy everyone.

Don't forget, we are talking about GUI from very beginning.

Anyways, did you open a bug? If not, I will do it myself.

1 Like