Fritzbox 7530 and 2 x Xiaomi AX3000T

Hey there,

I am trying to make my WLAN more stable and secure.

Got an original Fritzbox 7530 and purchased two Xiaomi AX3000T with openWRT recently.

My idea is to use the Fritz as the modem only and let the Xiaomis handle the Wifi.

So far I tried VLAN and DSA tutorials, but nothing lead to success. My last try was a bride on LAN 2 that uses 192.168.2.1, but when connected the LAN I didnt get a IP (yes I activated DHCP on the device)

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdab:901d:6723::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan3'
	list ports 'lan4'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.178.2'
	option netmask '255.255.255.0'
	option ip6assign '60'

config device
	option name 'wan'
	option macaddr 'cc:d8:43:14:87:c0'

config interface 'wan'
	option device 'wan'
	option proto 'dhcp'

config interface 'wan6'
	option device 'wan'
	option proto 'dhcpv6'

config device
	option type 'bridge'
	option name 'iot'
	list ports 'lan2'

config interface 'IOT'
	option proto 'static'
	option device 'iot'
	option ipaddr '192.168.2.1'
	option netmask '255.255.255.0'

config bridge-vlan
	option device 'iot'
	option vlan '20'

As of now I don't see the benefit of VLAN, since I do not need the Ethernet ports. Is that correct?

My Fritz will upstream the two routers with internet, so I have 2 LAN ports free (the one WAN is "empty" at the moment, someone told me there will be issues with NAT, whatever that means, I don't want to go to much in depth.).

Ah, the idea was to use the 2.4 Ghz wifi only for the IOT stuff. But then I remembered that the connection in the garden would not be possible via 5 Ghz. Anything speaks keeping the 2.4Ghz on the Fritzbox running on a different channel? (planned is 11 and 6).

You don't need to change any config on the Fritz.
https://openwrt.org/docs/guide-user/network/wifi/dumbap
https://openwrt.org/docs/guide-user/network/wifi/guestwifi/guestwifi_dumbap

Yes, you could create an IoT/guest wifi on the Fritz instead.

https://openwrt.org/docs/guide-user/network/wifi/guestwifi/configuration_webinterface

I wanted to exchange the "main" wifi for mobile, tablet etc. with the Xiaomi routers because they do perform a lot better.

Can I even enable guest wifi and have the other wifi off with the fritz?

just create the guest wifi there, and nothing else.

Ok, having an own Wifi network for IOT would only work if I can tell they can not talk to each other in the LAN, but do have internet access. Sure that is possible in guest wifi of a fritz?

Isn't that the whole point of an IoT/guest network ?

Have you read the links provided ?