FritzBox 7520 xDSL modem

I have installed openWRT 23.05.4 on my FritzBox 7520, like this tutorial:
https://openwrt.org/toh/avm/avm_fritz_box_7530
But the xDSL modem looks like not works? I get this errors in dmesg:

root@OpenWrt:~# dmesg | grep vrx
[   10.805982] vrx518: Intel(R) SmartPHY DSL(VRX518) PCIe EP/ACA Driver - version 2.1.0-k
[   10.810073] vrx518: Copyright (c) 2016 Intel Corporation.
[   10.836645] vrx518_tc:pcie_ep_probe: Failed to get total PCIe device number
[   10.836705] vrx518_tc:tc_drv_init: ep probe fail!
[   16.341900] vrx518_tc:pcie_ep_probe: Failed to get total PCIe device number
[   16.341962] vrx518_tc:tc_drv_init: ep probe fail!

Do I have the wrong xDSL modem driver? Can anybody help?

some units have an hardware bug in the dsl chip, have a look here:

and i guess you downloaded and installed the dsl drivers as for wiki page.

best!

edit: added github more updated info.

1 Like

You are right ... But what I have to do now? I have to use a patch?

do you see the dc_ep_clk_on failed error in dmsg? if so you need to build your own image with patch.

Yes, I see it on dmesg after booting. I know how to build my one image. I did it for a FritzBox 7362SL, but I dont know how to patch. I never do a patch. Can you help me, again?

i used patch from here on my 7530
https://patchwork.ozlabs.org/project/openwrt/patch/20230130224020.473703-1-jan@3e8.eu/
download the patch file and run git apply <.patch file> command in your local repo.

1 Like

Ok, is this correct? I downloaded the .diff file.

git apply ../ipq40xx-add-PCIe-magic-hack-to-improve-VRX518-compatibility.diff 
../ipq40xx-add-PCIe-magic-hack-to-improve-VRX518-compatibility.diff:37: trailing whitespace.
 
../ipq40xx-add-PCIe-magic-hack-to-improve-VRX518-compatibility.diff:41: trailing whitespace.
 
../ipq40xx-add-PCIe-magic-hack-to-improve-VRX518-compatibility.diff:43: trailing whitespace.
 
../ipq40xx-add-PCIe-magic-hack-to-improve-VRX518-compatibility.diff:47: space before tab in indent.
 	struct clk_bulk_data clks[QCOM_PCIE_2_1_0_MAX_CLOCKS];
../ipq40xx-add-PCIe-magic-hack-to-improve-VRX518-compatibility.diff:48: space before tab in indent.
 	struct reset_control *pci_reset;

should be. file /target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4019-fritzbox-7530.dts is modified, and /target/linux/ipq40xx/patches-5.15/997-pcie-qcom-host-magic.patch is created if you want to manually check or use -v for more verbose as for all commands as usual.

Sorry, I dont understand.
My downloaded file is not the correct file?

EDIT:
Ahhhhh, I see
/target/linux/ipq40xx/patches-5.15/997-pcie-qcom-host-magic.patch
is created.

1 Like

you did the correct procedure, with the correct dowloaded file. IF and only IF you want to manually check applied patch look at files i wrote above in your local repo.

OK, thank you. I will now build the image. I will give a report if all works.

look for this after boot once you flash patched image

root@modem:~# logread | grep magic
kern.info kernel: [    0.377967] qcom-pcie 40000000.pci: Applying PCIe host magic

and xdsl chip should work.

Ok, I will do. The image is building with 8 cores. It tooks a little bit of time to be complete. I will report you :wink:

on a side note i've always built for 23.05 not snapshot, i have no idea if kernel version is changed in snapshot

I have the same error? Did I something wrong?

root@OpenWrt:~# dmesg | grep vrx
[   11.701956] vrx518: Intel(R) SmartPHY DSL(VRX518) PCIe EP/ACA Driver - version 2.1.0-k
[   11.705722] vrx518: Copyright (c) 2016 Intel Corporation.
[   11.735943] vrx518_tc:pcie_ep_probe: Failed to get total PCIe device number
[   11.736000] vrx518_tc:tc_drv_init: ep probe fail!
[   17.537682] vrx518_tc:pcie_ep_probe: Failed to get total PCIe device number
[   17.537748] vrx518_tc:tc_drv_init: ep probe fail!
[   17.648811] kmodloader: dependency not loaded vrx518_tc
[   17.658197] kmodloader: - vrx518_tc - 0

logread | grep magic

and did you build snapshot or 23.05?

Yes, I habe v23.05.4 ...

Thu Aug 22 17:52:22 2024 kern.info kernel: [    0.378124] qcom-pcie 40000000.pci: Applying PCIe host magic

it should work, did you try to setup dsl connection?

No, I didnt. I will try the DSL connection.

No, DSL is not working. The DSL/Power led doesnt blink. I think it have to blink when the modem is doing the sync? I have ADSL here. My network config is:

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdeb:9a58:0969::/48'

config atm-bridge 'atm'
	option vpi '1'
	option vci '32'
	option encaps 'llc'
	option payload 'bridged'
	option nameprefix 'dsl'

config dsl 'dsl'
	option tone 'b'
	option annex 'j'
	option ds_snr_offset '0'
	option firmware '/lib/firmware/vdsl.bin'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	list dns '1.1.1.1'
	list dns '2.2.2.2'

config device
	option name 'dsl0'
	option macaddr 'D4:24:DD:D5:1B:8B'

config interface 'wan'
	option proto 'pppoe'
	option password 'username'
	option username 'password'
	option ipv6 'auto'
	option device 'dsl0.7'

config interface 'wwan'
	option proto 'dhcp'

EDIT:
FritzBoxes, sometimes very tricky ...