FritzBox 7490: red LED blinking twice after flashing?

Hi all,

I flashed a FritzBox 7490 recently. As I got my hands on another one I tried to flash that too, using the exact same files as with the first one.

I can use the eva_ramboot.py script to boot into OpenWRT via "ftp". I can transfer over the sysupgrade image.

After running sysupgrade -n ... the box reboots as expected.

But it does not boot properly. All I get are two blinks of the red LED. Then some seconds pause. Then again the same two blinks of the red LED.

This continues, I powered off after like half an hour.

I also tried a newer image, without success.

I tried the Micron image (maybe this FB is Micron-based), but the sysupgrade failed with "unsupported image".

Any idea why this red LED blinking shows up on only this one box? Any ideas how to fix it?

Kind Regards,
Johannes

You need to return to OEM software using AVM recovery tool, then check for "micron" in hidden info page and use proper install procedure.

Thanks for the fast reply.

I already tried that and the upgrade was refused by the sysupgrade. But now that I think properly, it might just be because the kernel and initram were non-micron based and hence refused the upgrade.

I'll try using micron...

Get the device back to factory firmware first and start as if it is fresh from the box.

I tried without reverting to OEM (using Linux, might be tricky).

I could do the sysupgrade, the box reboots and now the INFO led is flashing red constantly. The box responds to pings however, but I cannot login via SSH...

So a different error this time...

OK, after powering off I get the same "two red blinks then pause" for the INFO LED

Should blink green (or blue) during boot and stay steady on once OpenWRT boots, red is from AVM bootloader.

The device is hard to brick (albeit not impossible), but as long as you can get into ADAM2's ftpd implementation, you can start over again (without having to restore the OEM firmware first).

Thanks for the fast replies! I will try to revert to the AVM firmware and update it to the latest state. And then try flashing OpenWRT again...

OK, I could use the AVM recovery tool to go back to the OEM firmware (latest update 7.59).

Unfortunately now the eva_ramboot.py does no longer work, I cannot get it to boot the initram. From the poweron to the moment right before the box responds to pings it says "no route to host", as soon as the box responds it says "Connection refused".

Off to check the docs and try some more things...

Get older OEM firmware where eva_ramboot works.

Easier said than down. I only find the image and recovery tool in the current version 7.59. I have a 7.57 image, but that is not accepted by the box (no downgrade allowed).

Will keep searching...

On a FB4040 I could stop the boot process by using the AVM recovery tool for the "wrong" Fritzbox, (in my case recovery for the FB4020)
I could then FTP in and do all the steps, the script does, manually.
A serial console would be helpful too.

1 Like

OK, apparently I had to use 169.254.131.1 instead of 192.168.178.1 for eva_ramboot.py now.

OpenWRT was booted successfully now, I'll try to flash now.

I'll report back what happens.

Thanks for all the help!

Hmmm, flashing the normal non-micron upgrade brings me back to the INFO led blinking twice in red, then pausing.

I found no mention of micron in the support file I downloaded from the FritzBox after getting it back to the OEM firmware. So I do not think the Micron on will work.

Any ideas?