Fritzbox 7362 (SL) OpenWrt port

Are you sure about VLAN tag 101? The information I can find would be VLAN tag 7, if vodafone relies on Telekom infrastructure underneath - and VLAN tag 132 if they own the cables themselves.

Another issue seems to be "Line Mode: G.993.2 (VDSL2)" combined with "Data Rate: 15.471 Mb/s / 1.119 Mb/s", this looks an awful lot like you'd be using a non-vectoring fallback profile on a connection that would require a vectoring capable modem. Keep in mind that OpenWrt is only allowed to ship non-vectoring enabled xDSL firmware blobs, if you do want a vectoring enabled one, you do have supply a firmware file with vectoring support yourself.

Additionally to the advice from @slh regarding the VLAN tag - Vodafone has also different prefixes depending on your contract. To add insult to injury, the username written to you might not be the one you need.

Back when i was using them, i had to use the "arcor.komplet/abxxxxx" prefix, but there are also "vodafone.komplett/xxxxxxxxx" around. So this might also need additional trial-and error from your side.

Hey thanks for the fast answers! I also seeked helped in the irc channel and I changed the line

option ifname'dsl0.101'
option ifname'dsl0.7'

and tadaa it works.

Also I followed the instrucitons here ( to get 993.5 vectoring working and it works like a charm.

Thank you a lot =)

ps.: please consider to add the extracting of the firmware etc. like explained in the link above to the wiki.

AVM does not freely distribute that firmware AFAIK. Having it in the wiki is already a bit of a grey area probably; providing a script that comes with OpenWrt to just extract it might be even more so.


You used the firmware of the FB 7360?

I tried to extract the 7362SL blob of the 7.10 but it failed.

Also with the firmware file from the 7360 my modem doesn't work

1 Like

Do the Lan Ports 3+4, which only support 100 Mbit/s, work for you? I have a Fritz!Box 7262 SL 1&1 branded.

If I try to apply vlan config on them, there's a good chance the device freezes. It recognizes the connections as gigabit although my Zyxel switch says it's only 100. And the ports are dead on layer 2 and higher levels. Packages don't go through.

Jep, there definitly is a regression with the xrx200 switch.

OpenWrt 19.07.7 Kernel 4.14.221 supports ports 3 + 4
Openwrt 21.02.0-rc1 Kernel 5.4.111 ports 3 + 4 are dead

root@OpenWrt:~# dmesg|grep -A5 -B5 PHY
[    0.163028] pinctrl core: initialized pinctrl subsystem
[    0.170653] NET: Registered protocol family 16
[    0.183980] dcdc-xrx200 1f106a00.dcdc: Core Voltage : 1016 mV
[    0.198588] pinctrl-xway 1e100b10.pinmux: Init done
[    0.205140] dma-xway 1e104100.dma: Init done - hw rev: 7, ports: 7, channels: 28
[    0.216895] pcie-xrx200 1d900000.pcie: failed to get the PCIe PHY
[    0.265910] usbcore: registered new interface driver usbfs
[    0.271499] usbcore: registered new interface driver hub
[    0.276869] usbcore: registered new device driver usb
[    0.282522] workqueue: max_active 576 requested for napi_workq is out of range, clamping between 1 and 512
[    0.294467] clocksource: Switched to clocksource MIPS
[    0.708199] NET: Registered protocol family 10
[    0.715876] Segment Routing with IPv6
[    0.718218] NET: Registered protocol family 17
[    0.722769] bridge: filtering via arp/ip/ip6tables is no longer available by default. Update your scripts to load br_netfilter if you need this.
[    0.735555] 8021q: 802.1Q VLAN Support v1.8
[    0.746142] pcie-xrx200 1d900000.pcie: failed to get the PCIe PHY
[    0.859313] libphy: lantiq,xrx200-mdio: probed
[    0.869051] net-xrx200: invalid MAC, using random
[    0.872575] Atheros 8030 ethernet 0:00: attached PHY driver [Atheros 8030 ethernet] (mii_bus:phy_addr=0:00, irq=POLL)
[    0.883256] Atheros 8030 ethernet 0:01: attached PHY driver [Atheros 8030 ethernet] (mii_bus:phy_addr=0:01, irq=POLL)
[    0.894242] Intel XWAY PHY11G (xRX v1.2 integrated) 0:11: attached PHY driver [Intel XWAY PHY11G (xRX v1.2 integrated)] (mii_bus:phy_addr=0:11, irq=POLL)
[    0.907971] Intel XWAY PHY11G (xRX v1.2 integrated) 0:13: attached PHY driver [Intel XWAY PHY11G (xRX v1.2 integrated)] (mii_bus:phy_addr=0:13, irq=POLL)
[    1.046546] PCI host bridge /fpi@10000000/pcie@d900000 ranges:
[    1.051221] PCI host bridge to bus 0000:00
[    1.055083] pci_bus 0000:00: root bus resource [mem 0x1c000000-0x1cffffff]
[    1.061969] pci_bus 0000:00: root bus resource [io  0x1d800000-0x1d8fffff]
[    1.068840] pci_bus 0000:00: root bus resource [??? 0x00000000 flags 0x0]

Notably might be the line ”failed to get the PCIe PHY“ which does not appear in 19.07.7.

Same at the 3390, 3+4 not working

Model AVM FRITZ!Box 3390
Architecture xRX200 rev 1.2
Firmware Version OpenWrt SNAPSHOT r16833-962d530dea / LuCI Master git-21.147.31971-74be304
Kernel Version 5.4.121

root@OpenWrt3390:~# dmesg|grep failed
[ 0.286747] pcie-xrx200 1d900000.pcie: failed to get the PCIe PHY
[ 0.814252] pcie-xrx200 1d900000.pcie: failed to get the PCIe PHY

I opened a bug:[0]=&sev[0]=&pri[0]=&due[0]=&reported[0]=&cat[0]=&status[0]=open&percent[0]=&opened=&dev=&closed=&duedatefrom=&duedateto=&changedfrom=&changedto=&openedfrom=&openedto=&closedfrom=&closedto=

Worth noting, I think it might be because of this commit:;a=commit;h=f8ea7c53fd227a9c21f0ca45a2c3345312ea54b5

Is this still true for the final 21.02.0 release? I plan to openwrtize one of this devices but need all of the ethernet ports :see_no_evil:

Use 19.07, for me the don't work

Perhaps give a current OpenWrt/ master snapshot a try, lantiq has moved to DSA there, which re-shuffles the cards (won't help 21.02.x by itself, but it would be interesting to evaluate the current status for the next release after it).

I've tried latest master (a1939e7e37) and it's the same as 21.02. Link is flapping, but for a moment while it's up, ping is working and the data counters in OpenWrt increase. I can't find anything obvious in commits besides removing some extra drivers, but it still doesn't work if I re-enable them in menuconfig.

1 Like

Did you try to revert this commit?;a=commit;h=f8ea7c53fd227a9c21f0ca45a2c3345312ea54b5


I would now be interested to know what happens next here. I can also confirm that the 7362 with the current openwrt v21 does not support all 4 ports. With the v19 it works now again with all 4 Ports. But on the info page about the device 7326 there is nothing noticed about this restriction. Can I contribute something to have a progress here?


It's possible that phy support was broken early on . I would recommend build some test images before those changes on vr9.dtsi

|2021-06-26|Martin Blumenstingl|lantiq: xrx200: switch the subtarget to the mainline DSA driver
|2021-04-12|Mathias Kresin|lantiq: dts: mark PCI bridges as such
|2021-04-03|Joachim Cerny|lantiq: VR9: fix gpio-hog by defining the GPIO ranges
|2021-02-28|Mathias Kresin|lantiq: vr9: set the usb led trigger via devicetree
|2020-10-19|Adrian Schmutzler|lantiq: remove support for kernel 4.19
|2020-03-16|Mathias Kresin|lantiq: copy target to kernel 5.4

I've seen no reports from 7360 or 7362 owners in recent polls . I own FB 7412
but seen 7360 for equivalent of ~12eur in my country

I just added a topic about LAN 3 and 4 not working properly with OpenWrt 21.02.1 on FRITZ!Box 7362 SL before I found this thread.

Different from what I read here, I observed the following: when I connect a 100baseT-only device to LAN 3 or 4, everything works as expected.


This topic was intended for adding support for this specific device.
Since official 21.02 images are available since quite a while, I will set a timer for this topic to close.


Because specific problems for this device with official releases are better handled in separate topics, in order to make finding relevant information easier.

Therefore: Please open new topics for any open issues with this device.

Thanks! :slight_smile:

Exactly same problem here with a AVM Fritzbox 7360 SL (7360 v1).
I suspect that a Fritzbox 7360 v2 has the same problem.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.