Fritzbox 4040: upgrading to version 23.05 failed

I just tried to upgrade my FB 4040 from version 22.03.5 to the latest 23.05 using the attended/guided upgrade process, but the process failed. Here's what I did:

I used Luci to request a customized firmware image. The first attempt failed due to the wolfssl issue and after reading some discussions about it, I unselected every package I could find related to wolfssl and added these packages to be included in the new image:

libmbedtls
libustream-mbedtls
px5g-mbedtls
wpad-basic-mbedtls

Then I requested and downloaded the new image. Luci started the upgrade process, but it never finished even after half an hour. So I started again, this time I stored the new image to my pc and tried install it by selecting this image. This time, Lucid gave me this warning:

Sun Apr 7 17:52:42 CEST 2024 upgrade: The device is supported, but the config is incompatible to the new image (1.0->1.1). Please upgrade without keeping config (sysupgrade -n). Sun Apr 7 17:52:42 CEST 2024 upgrade: Config cannot be migrated from swconfig to DSA Image check failed.

I definitely do not want to loose my configurations, so doing a sysupgrade -n is not an option!

No I am stuck and any help will be appreciated very much! What did I do wrong, how do I need to do this upgrade correctly?

There's no other way, you need to wipe and configure it from scratch, there's no automatic migrations from swconfig to DSA.

If that is the case, then I will rather keep using version 22 unless there are very, very important security issues that can not be solved in this "old" version and that would force me to upgrade asap. Apart from that, I will postpone the upgrade until I will find enough time during my next big holiday from job, maybe in 2030 or so...

I have two FB4040, that was quiet helpfull for the swconfig --> DSA migration.
You might post your /etc/config/network here, and I (or maybe others) might assist in the migration.
Are you using VLANs ?

Many thanks for the offer! I really appreciate it, and I will post the configuration, as soon as I finished anonymizing it.

Yes. Is that a problem with the new technique?

Well, I still have a TP 1043, which I kept for backup, after I switched to the FB4040. I know that the TP has very limited memory, but would it be possible to install just the basic system, then configure the network from scratch and copy the configuration to the FB?

If migration is not possible, how about providing some templates, that can be used as basic configuration and then be customized? Two or three templated should be enough, I think: one without any VLAN, one with VLAN, one with WiFi networks. I know there a plenty of more possibilities, but if users can load a template, that fits their need at best, and then use LUCI to change it, I think that would be sufficient.

Here is my /etc/config/network, using VLANs 1 and 10 for LAN and GUEST
Hope this helps ... (I'm not using IPv6)

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd20:f521:434a::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config interface 'lan'
	option device 'br-lan.1'
	option proto 'static'
	option ipaddr '192.168.0.1'
	option netmask '255.255.255.0'
	option delegate '0'

config interface 'wan'
	option device 'wan'
	option proto 'dhcp'
	option hostname '*'
	option vendorid 'openwrt'	// required for vaderfone DE

config interface 'wan6'
	option device 'wan'
	option proto 'dhcpv6'

config bridge-vlan
	option device 'br-lan'
	option vlan '1'
	list ports 'lan1:t'		// trunk port going to managed switch
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config bridge-vlan
	option device 'br-lan'
	option vlan '10'
	list ports 'lan1:t'		// trunk port going to managed switch

config interface 'guest'
	option proto 'static'
	option device 'br-lan.10'
	option ipaddr '192.168.66.1'
	option netmask '255.255.255.0'

config device
	option name 'br-lan.1'
	option type '8021q'
	option ifname 'br-lan'
	option vid '1'
	option ipv6 '0'

config device
	option name 'br-lan.10'
	option type '8021q'
	option ifname 'br-lan'
	option vid '10'
	option ipv6 '0'

config device
	option name 'wan'

config interface 'modem'		// to be able to access my cable modem on 192.168.100.1
	option proto 'static'
	option device '@wan'
	option ipaddr '192.168.100.2'
	option netmask '255.255.255.0'

Yes, thank you very much! This will certainly be helpful!

But I have to say: this does not look very different to "swconfig". Is this really the new "DSA" configuration?

You will need to redo /etc/config/network. You should remove that file from config backup, rest of config can be restored as is. Might take a bit of command line to remove one file from a tar file.

So I can keep /etc/config/* from release 22, if I just replace /etc/config/network with the modified version, and firewall, dnsmasq, and whatever is configured now will continue to work in the same way?

It is just one file, /etc/config/network, why an automated migration is not possible?

You delete /etc/config/network from tarball to restore and then after boot
You have to retype network and switch config via 192.168.1.1

No one said it was impossible, just that there isn't one in place as of this moment in time. I would guess that it's due to the massive amount of different targets, devices and configurations that makes it a complicated task.

Can't I just replace the file /etc/config/network within the back up tarball and restore the settings using this new tarball after upgrading?

You remove /etc/config/network from the backup tarball and then recreate it in place.