FritzBox 4040 (OpenWrt 22.03.3) behind Fritzbox 7590

I have been running the 4040 behind the 7590 for 2.5 years with openwrt 19.07.5. The setup was no problem at all.
Now I have installed the upgrade to 20.03.3 and just get connection from the PC to the 4040.
The strange thing is, the 4040 has port eth0 for the WAN and eth1 to eth4 for the Lan.
When I start the 4040 and on eth0 is the 7590 and on eth1 the PC, configures openwrt the following:
a bridge for the lan with eth0
and eth1 for the WAN.
If I try to change this e.g. eth1 for the LAN and eth0 for the WAN, it resets all settings completely on a reboot.
Not to mention a way to the internet.
I don't know what the guys have screwed together here.
I must have rebooted the 4040 30 times in the meantime with no result.
I get access to the 4040 ( from the PC, but no access to the 7590 (
Thanks and best regards

Did you keep settings when you ran the upgrade? The settings from 19.07 > 22.03 are not compatbile and upgrading (with 'keep settings') is not supported. If you did this, you need to reset to defaults and then configure from scratch (do not try to use the backup files except as a general reference for you to remember how things were previously configured).

I reset openwrt 20.03.3 with "firstboot -y reboot" and after I logged back into the Fritzbox 4040 with the source was restored.
However, openwrt immediately configured the LAN as a bridge.
Why only God knows. Why bridge? If someone needs this function, let him do it alone!
I then managed to set up the network configuration again, that I got PC --> 4040 (openwrt) --> Fritzbox 7590 (with FritzOS) into the internet.
It was all always step by step "save and aply".
Then I tried a reboot and found that all, really all settings were completely reset. Even the software update was gone!
This means a complete new configuration.
This is a big joke!!!
Should I start the entire configuration from scratch every time the power is interrupted?
This did not exist in version 19.07.!
More than: "save and aply" is not possible.

Translated with (free version)

Actually, the majority of users will want the lan configured with a bridge. This allows the lan to operate on both ethernet and wifi. Even without ethernet, a bridge is required if more than one physical interface is connected to the network, including the radios (i.e. 2.4G and 5G). So this is a practical and useful default condition. I would say that advanced users who do not want a bridge can remove the bridge during configuration.

What software update? did you use opkg upgrade (or the LuCI "upgrade packages" feature), or are you talking about sysupgrade?

No, obviously not. but something is wrong and we need to figure out what.

Let's see the output of:

ubus call system board
df -h

many things have changed siginificantly moving from 19.07 to currect version 22.03.x of openwrt. for me the intro of DSA and related implications was key to understand. I am using 3 x AVM 4040 behind AVM 7490 with VLAN seperated networks (IOT, LAN and Guests) with multiple SSIDs and fast transition between the APs.
It took almost 2 years to get DSA and the switch portion properly working for AVM 4040. Before there were patches needed. AVM 4040 is based on ipq40xx module, which has been ported to DSA but is depending on kernel 5.15.
For stable version of openwrt there are still architectures that need porting to kernel 5.15. So 22.03.3 uses kernel 5.10 for AVM 4040.
As a result and least for my use cases I could not get VLAN and the switch to work.
Just tried today about latests 22.03.3 version but it still has kernel 5.10 and because of this DSA does not work for AVM 4040 in 22.03.3.
Suggest you use the latest snaphot for AVM 4040, which has kernel 5.15 and working DSA and make yourself familar with DSA and the setup to configure the Network. There are detailed video tutorials about this.

Thank you for your explanations.

My English is unfortunately not so good that I can watch these instructions in a video.
I have completely reinstalled the 20.03.3 once again.

I have had no problems setting up a VPN with WireGuard in version 19.0x. and version 21.0x.

Only WireGuard in the 4040 with version 22.03.3 does not want to succeed.

I have basically not changed anything on the peers, also not on the forwarding in the FriBo 7590. WG0 has the IP on my router. The WG0 in the 4040 also works, because I can reach the in the LAN from my PC.

Unfortunately something in the firewall seems not to work.

I forgot to tell you that I deleted the bridge and the LAN works over eth0.

The access to the internet works, an access from the internet to my homeserver with https also. But nothing arrives at WG0 from the outside.

Do I have a security problem when I go back to 19.0x? Because there have been no updates for a long time.

For my low demands that would be enough, because there everything worked immediately.

Yes, serious ones.

There won't be any, it's been EOL for well over half a year now.

Thank you.
Than I neet help.
I have seen in the forums that many have big problems with the 22.03.3 and OpenWrt.
I noticed that for the earlier versions of openWRT there were the following packages for WireGuard:





For the 22.03.3 only is offered:




The package "wireguard" itself is now missing.

Why is that?
I install the packages witz luci.

Is there an exact manual for WireGuard somewhere that also works for the 22.03.3?

Because according to the instructions with which I have installed on the 19.0x. and 21.0x. it does not work.

I do not understand what is different now.

I do not use the bridge.

Now I looked at the todo to the V-Lans and tried what happens when I turn off the V-Lan functionality....

The connection to the router was gone and I no longer get a log in. I reach it with ping but a ssh root@ is rejected. Of course I deleted the corresponding key in .ssh/known_hosts.

So I can't even reset it anymore with: firstboot on the Konsohle.

Does anyone know advice?

Please help me....
When I start the box in the filesave mode, I can ping it but I can't login with ssh.
Is there another way to log into the system to change the config for the network?

Thanks for your support.