FritzBox 4040, openwrt 19.07.5

I installed openwrt 19.07.5 on the Fritz Box 4040 and specified it for the WAN and route For the local LAN of the box the assigned.
After saving and applying came from the box after about 60 s the message an error has occurred and the settings are reset. Waiting time 90 s.
After 5 min I disconnected the box from the power and now it is no longer accessible.
The instructions to put the box in the Securemod do not work.
Can someone help me?
Thank youfanifeey

Hallo Leute,

gibt es eventuell eine deutsche Anleitung wie man in das openwrt gelangt wenn das Userintervace nicht mehr ansprechbar ist?
Kann doch nicht sein, dass ich das Teil auf den Müll schmeißen muss nur weil sich das Teil nach dem Abspeichern einer Veränderung tot stellt.

Keine Ahnung ob es was auf Deutsch gibt...
but after rollback of unsuccessful config changes you should be back to the original values.

Have you tried for example setting the local IP of your computer without waiting for DHCP? Something like should do, since the router will be at with a default installation.

The router responds to a ping after approx. 20 sec for 5 sec with its IP
However, it does not respond to a login via FTP or ssh.

Sorry, I might be wrong on the initial IP for the router, I did the setup last year.

According to the docs it should be for the original firmware. If it was already running Openwrt, then it's really on .1.1

To recap, set your PC static IP to:

  • in case your router has the new subnet setting but fails to run dhcp
  • in case it has the default openwrt subnet and still no dhcp
  • if somehow we're dealing with the stock firmware (though I don't think this is at all possible)

Also, check out these scripts.

I read the "failsafe mode" is only accessible if you have previously installed "firmware from a SquashFS image".
I did the initial installation with the help of ftp.
So what other options are there?

I still don't know what the situation on the ground is :slight_smile:
You could always try the ftp installation again: you'll have to start from scratch but that is just what you want now.

However, the router rejects a connection via ftp as it is now.
So how do I reinstall the image?
Thank you for the effort so far!

Honestly, it's rather unlikely that the router is completely dead. Easier is that some change went unnoticed and that messed up the scenario.

What do you have on the local PC? Windows, Linux or (gasp) Mac? And how comfortable are you with cmdline tools?

I use ARCH-Linux.
On the komando line, however, I need a manual.
I'm not adept at that.

I have two of these boxes and have flashed both of them a couple of times,
they are "almost" unbrickable.
From a session on the serial console I know, that you have almost 15 sec.
to establish the FTP connection and enter username/password to stop the boot process.

In case you have a windows PC, you can try the AVM Recovery Tool
to restore the AVM Software on the box.
Also possible is to use the Recovery Tool for another Fritzbox (e.g. FB4020)
This will end up with an error message on your PC but will have
stopped the boot process and allows you the establish the ftp connection.
(I've done both with success)



Try @tomtom 's suggestion, first.

It's a miracle!
I don't know what happened when i saved it in the router.
The router not only responded to ping, but also to ping
There was no reply to ftp; ssh; http
On he reigned on ftp and reported a connection with adam2.
So I was able to reinstall the eva-image as normal.
In the meantime, everything works wonderfully.
How the ping on could work, I don't know.
Thank you for your help.

1 Like

Very well.
In this case please edit the subject of this thread marking it solved and accept @tomtom 's answer.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.