FritzBox 4020 FTP install doesn't work

I would like to flash my FritzBox 4020 with openwrt.

ftp -n

ftp> quote USER adam2
ftp> quote PASS adam2
ftp> binary
ftp> debug
ftp> quote MEDIA FLSH
ftp> put openwrt-sysupgrade.bin mtd1

But when I do the last command the console say:

ftp> openwrt-19.07.7-ath79-generic-avm_fritz4020-squashfs-sysupgrade.bin mtd1
---> PORT 192,168,178,20,243,164
502 Command not implemented
---> STOR mtd1
425 can't open data connection

What can I do?

Looking at it appears there's an extra command which might be useful: passive

the command passive doesnt work

You're not specifying OS used, but passive mode isn't supported by the ftp
client in win10, you'll need something else.

Where is passive mode supported
I have kali linux

Is your computer on the same subnet (192.168.178.x) ?

If not, are both ports 20 and 21 permitted through any intermediate devices?

linux ftp (at least the one that comes with Fedora) supports passive, but passive also requires firewall ports to be opened, or temp shut down.

ftp> help passive
passive         enter passive transfer mode
ftp> passive
Passive mode off.
ftp> passive
Passive mode on.

modified the subject, this issue has nothing to do with openwrt.

yes its in the same

What happens when you try to install OpenWrt via fritzflash?

Its says: No Immage found! Use --image
But how can I use --image

do you have the files specified in the code, and are they named accordingly ?

"219": {
            "gluon": [
            "openwrt": [

(if running Windows, to be able to use parameters, you probably have to execute the .py from a cmd prompt)

Thanks it works :slight_smile:

if everything else fails, RTFM (or in this case, the source code) :wink:

1 Like

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.