Fritzbox 3370 ADSL doesn't works on Annex A line

Hi all,
I've successfully installed OpenWrt 19.07.5 on my FRITZ!Box 3370, but it's impossible to get ADSL to work. I'm on an annex A line and I tryed both 3370 versions, german (art. 2000-2478) and international (art. 2000-2563), with no luck at all. Same problem with previous OpenWrt versions.
Both routers work ok on stock firmware (international version works out of box, german one after flashing international firmware) but not with OpenWrt.
The interface stays down and vdsl_cpe_control says 'DSL_CPE: Wrong combination of DSL PHY Firmware and hybrid type used! Please change one of it.'
I know that german version has a different hardware build for Annex B and isn't supposed to work even if it does with the Fritz firmware, but international version should work.
I have no idea how to fix it, maybe someone can put me on the right path!
Kind regards.

In theory you are right, the "international" version (which actually is the version for Austria and Switzerland, both of which use Annex A) should work for any Annex A line. Judging from your error message it seems like you're already trying to load the Annex A firmware, so I don't really know how to improve that.

It's interesting that both versions work on Annex A with the manufacturer firmware. This might be one of the rare cases of a "hybrid", i.e. a combination of filters and transformers, that can be switched to both annexes. Exactly how they do that might be AVM's secret, maybe one that OpenWrt can or does not invoke before loading the modem firmware into the chipset, and consequently both devices (if true, being really the same device under the hood) stay on Annex B by default.

Many thanks for your reply, your explanation is very similar to what I thought after so many tests. I think the stock firmware switches the hybrid, so I'm wondering if there is a way to get OpenWrt to do the same thing before loading the driver. I remember I found something similar when reading about the Netgear DM200, but I don't know where to start.
I have verified that the DSL hardware section of the two routers versions is heavily different, but both are equipped with the UTB01930S transformer, so I think they are both set by default on annex B, but for sure they can be switched to A, however, as you say, I have no idea how to do it.