Fritz ! Repeater 1200 - Installation - Missing WLAN iw dev

Good Evening together,

i am complete new to openwrt - but i running 2 "nodes" as accesspoints allready.

Actually i try to install 19.07.7 on the Fritz 1200 by using this instruction:

Problem is now:
I stucking on point 5. I mean, i not realy stuck, but: my Openwrt has load into the ram and booted up.
At this Moment, i has think to test, how good openwrt works on this fritz, because - all informations are rare and i will not brick anythin.
Ok: What is my problem now?

it's seems, that the image comes with ath10k-firmware-qca4019-ct and kmod-ath10k-ct packages as a standard.
But at this moment - by point 5 - i can't search for wireless. This option is completly missing in LuCi

i try:

iw dev: show nothing
opkg install pciutils -> lspci : show nothing (ok was a try)

my question is now: is this behavior normal and after upgrade and burn to ROM i can use wifi?
can i asked the a comand, to show the correct hardware (maybe newer ath chipset?)

i hope, that someone can help me


=> At this time: I using also 2 Baracuda Next Gen with OpenWRT. Works great, but for accesspoint with meshfunction it's a little bit to large and oversized.
(At this Moment simple setup: 1x Mesh, 1xAP per Baracuda --- but: all on 2,4GHZ with only one radio)

If you've already booted openwrt initramfs you should be at 8?

Not sure initramfs contains everything you need for wireless, it's just a bridge head to get openwrt installed properly.

Hello Frollic...

Arghs! The Wiki has been Updated (oh from me :-/ ) and the Point 5 is now Point 7.
I am now between point 7 und point 8.
Box is running but... without the WLAN Interfaces.

And now i am scared to flash it on the rom, because i didn't know how i can get back to AVM

then don't do it ...

case closed.

1 Like

Oh so easy?
... maybe, you can explain me, why your answer is so short as it is?

IMHO the AVM-Hardware has much power, for slightly more money the other Hardware ?

I have running the OpenWRT from RAM in the Repeater - i think initframes are loaded.

Is there a way to read out Hardware-IDs ?
Is there a way to save the old flash?
Sorry, but i didn't find actuall some helpfull informations for this?

FritzOS can commonly be restored with a recovery tool which runs on Windows, although I have not tried it for this particular device:

I am not sure what you mean by "initframes are loaded".

OpenWrt's initramfs image is missing some packages which are however required for WLAN operation.
You should flash the sysupgrade image before doing any WLAN tests.

Check the environment when the bootloader is running, or the support data which can be generated from within FritzOS.

For the NAND flash, use nanddump from the nand-utils package while the OpenWrt initramfs is running.
For NOR flash, if applicable, you could take a copy of the respective /proc/mtdX pseudo-files.
The list of flash partitions is shown in /proc/mtd and the kernel boot log (dmesg). Details are available with mtdinfo -a.

1 Like

Yes, that was the Solution for my personal Problems.
My idea was test befor flash.
But, yeah i have to flash it and now it's working.

802.11s Mesh is working (B/g/n tested)
By using wpad mesh openssl package - i can also use WPA3.

I will this knowledge add in the Wiki.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

1 Like

Please add also that Openwrt 21 is broken currently, ihave no wiki access

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.