Fritz!Box7520 unable to establish an PPPoE connection

I bought a FB 7520 as it is one of the supported OpenWrt DSL routers.

So far it has been pretty frustrating..

Issue:
Unable to establish a PPoE connection (Timeout waiting for PADO packets)

What i tried:
Many different things i found on the OpenWrt forum and through looking up the issue(s) including:
different /etc/config/network configs
AVM firmware instead of the one provided on the OpenWrt site
Flashing back stock firmware to confirm it is indeed working only unable to establish the connection with PPPoE on OpenWrt
Raising the connection timeout/stay-alive

Details:
I use O2 (a German internet and mobile provider)

Log:

> Fri Mar 22 22:39:47 2024 daemon.notice netifd: Interface 'wan' is setting up now
> Fri Mar 22 22:39:47 2024 daemon.info pppd[11597]: Plugin pppoe.so loaded.
> Fri Mar 22 22:39:47 2024 daemon.info pppd[11597]: PPPoE plugin from pppd 2.4.9
> Fri Mar 22 22:39:48 2024 daemon.notice pppd[11597]: pppd 2.4.9 started by root, uid 0
> Fri Mar 22 22:39:48 2024 daemon.warn odhcpd[1167]: No default route present, overriding ra_lifetime!
> Fri Mar 22 22:40:03 2024 daemon.warn pppd[11597]: Timeout waiting for PADO packets
> Fri Mar 22 22:40:03 2024 daemon.err pppd[11597]: Unable to complete PPPoE Discovery
> Fri Mar 22 22:40:03 2024 daemon.info pppd[11597]: Exit.

cat /etc/config/network

> config interface 'loopback'
>         option device 'lo'
>         option proto 'static'
>         option ipaddr '127.0.0.1'
>         option netmask '255.0.0.0'
> 
> config globals 'globals'
>         option ula_prefix 'fda0:5faf:1ba9::/48'
> 
> config atm-bridge 'atm'
>         option vpi '1'
>         option vci '32'
>         option encaps 'llc'
>         option payload 'bridged'
>         option nameprefix 'dsl'
> 
> config dsl 'dsl'
>         option annex 'j'
>         option tone 'b'
>         option ds_snr_offset '0'
> 
> config device
>         option name 'br-lan'
>         option type 'bridge'
>         list ports 'lan1'
>         list ports 'lan2'
>         list ports 'lan3'
>         list ports 'lan4'
> 
> config interface 'lan'
>         option device 'br-lan'
>         option proto 'static'
>         option ipaddr '192.168.1.1'
>         option netmask '255.255.255.0'
>         option ip6assign '60'
> 
> config device
>         option name 'dsl0'
>         option macaddr 'redacted'
> 
> config interface 'wan'
>         option device 'dsl0.7'
>         option proto 'pppoe'
>         option username 'redacted'
>         option password 'redacted'
>         option ipv6 '1'
> 
> config interface 'wan6'
>         option device '@wan'
>         option proto 'dhcpv6'

Weird about this is that it is able to connect but not able to login via PPPoE, i might be missing something very simple though.
Also weird was that the stock firmware had the same Timeout waiting for PADO packets error message on the first connection try.

Any help is appreciated as i would love to get this to work with OpenWrt.

I have (also using a 7520 under OpenWrt for an O2 VDSL2 Link in Germany (100/40), but I have use the 7520 as bridged-modem only, so have no working modem-router config I could share):

config device
        option type '8021q'
        option ifname 'dsl0'
        option vid '7'
        option name 'dsl0.7'

to actually create that VLAN 7 on DSL, but I am not sure that is required

Also in dsl I have:

config dsl 'dsl'
        option tone 'b'
        option annex 'b'
        option ds_snr_offset '0'
``
As all VDSL in Germany is Annex B (Annex J is an ADSL thing only), but since the modem reached showtime the dsl sync is not your issue so this does not really matter. But getting the VLAN right still matters.

ON my primary router (connected via eth2.7 to the bridged-modem I have:

config interface 'wan'
option hostname 'turris'
option ipv6 '1'
option proto 'pppoe'
option username 'DSLXXXXXXXX@s93.bbi-o2.de'
option password 'XXXXXXXX'
option force_link '1'
option device 'eth2.7'

with the Xs in the username representing 13 numbers, and in the password 10 alphanumeric values these values are available in the O2 Kundencenter for each customer, but you likely already have these.

Thanks for your rapid and detailed answer and for sharing your config.

I appended the part with the config device and i changed the dsl option tone and annex to b, restarted the router and sadly still the same errors.

It might be worth a shot to try to initialize the connection via my PC.

(I recognize your username i saw your reply's in a post about a similar issue with the 7520 while i was searching for a solution :joy: )

The DSL configuration and firmware are not the issue, as a connection has already been established. The configuration of the WAN interface also looks good.

Does the message dc_ep_clk_on failed show up in the kernel log? If yes, you need to build OpenWrt yourself with an additional patch.

Mmmh, then it is time to edit
/etc/ppp/options and replace #debug with debug that is remove the hash sign, which might make pppd a bit more verbose (though Timeout waiting for PADO packets already indicates your pppd sent a PADI and nothing came back...)

Yep, that error appears twice:

[   10.161075] vrx518 0000:01:00.0: dc_ep_clk_on failed

Fri Mar 22 23:48:10 2024 kern.err kernel: [   10.161075] vrx518 0000:01:00.0: dc_ep_clk_on failed
nano

So on compiling it myself i guess :sweat_smile: that will take some time..

Alright,
here is the log:

Sat Mar 23 00:31:36 2024 daemon.notice netifd: Interface 'wan' is setting up now
Sat Mar 23 00:31:36 2024 daemon.info pppd[19427]: Plugin pppoe.so loaded.
Sat Mar 23 00:31:36 2024 daemon.info pppd[19427]: PPPoE plugin from pppd 2.4.9
Sat Mar 23 00:31:36 2024 daemon.notice pppd[19427]: pppd 2.4.9 started by root, uid 0
Sat Mar 23 00:31:36 2024 daemon.debug pppd[19427]: Send PPPOE Discovery V1T1 PADI session 0x0 length 12
Sat Mar 23 00:31:36 2024 daemon.debug pppd[19427]:  dst ff:ff:ff:ff:ff:ff  src 3c:37:12:82:85:1a
Sat Mar 23 00:31:36 2024 daemon.debug pppd[19427]:  [service-name] [host-uniq  e3 4b 00 00]
Sat Mar 23 00:31:37 2024 daemon.warn odhcpd[1168]: No default route present, overriding ra_lifetime!
Sat Mar 23 00:31:41 2024 daemon.debug pppd[19427]: Send PPPOE Discovery V1T1 PADI session 0x0 length 12
Sat Mar 23 00:31:41 2024 daemon.debug pppd[19427]:  dst ff:ff:ff:ff:ff:ff  src 3c:37:12:82:85:1a
Sat Mar 23 00:31:41 2024 daemon.debug pppd[19427]:  [service-name] [host-uniq  e3 4b 00 00]
Sat Mar 23 00:31:46 2024 daemon.debug pppd[19427]: Send PPPOE Discovery V1T1 PADI session 0x0 length 12
Sat Mar 23 00:31:46 2024 daemon.debug pppd[19427]:  dst ff:ff:ff:ff:ff:ff  src 3c:37:12:82:85:1a
Sat Mar 23 00:31:46 2024 daemon.debug pppd[19427]:  [service-name] [host-uniq  e3 4b 00 00]
Sat Mar 23 00:31:51 2024 daemon.err pppd[19427]: select (waitForPADO): Interrupted system call
Sat Mar 23 00:31:51 2024 daemon.warn pppd[19427]: Timeout waiting for PADO packets
Sat Mar 23 00:31:51 2024 daemon.err pppd[19427]: Unable to complete PPPoE Discovery
Sat Mar 23 00:31:51 2024 daemon.info pppd[19427]: Exit.

I read a few messages in the thread, am i not just able to update to the latest snapshot?

No, that patch hasn't been included in OpenWrt so far, so you still have to build your own image.

And note that the unchanged patch won't apply to the current main branch (due to kernel updates, as noted in the last message in the linked thread). But it probably still applies to the 23.05 branch.

So, i installed a build with your patch included and it works now.

The build i installed is from this post: Adding support for VRX518 (and maybe VRX320) - #441 by wilsonyan from the user wilsonyan.

I would have liked to build it myself but that was the quicker option.

One thing that is quiet strange but i would guess it is a bug, in the overview it shows line mode as G.993.2 but the speed i get correlates to the line mode G.993.5 that the box showed on stock firmware.

Anyways, thanks for your patch ant pointing me to that thread now my router works with OpenWrt instead of my previous setup with router with custom firmware + modem :partying_face:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.