Fritz!Box 7530: Add wan-port with vlan?

The Fritz!Box 7530 has no WAN port. So I just wanted to configure the first port of the switch as wan port. But the dhcp just does not work on a vlan interface. You can easily put your own network with your own DHCP server for the clients on a VLAN. Just DHCP client is not working. :confused:

I tried

  • master build with 4.19 kernel
  • master build with 5.4 kernel
  • 19.07.4

The network config looks like this

config interface 'wan'
	option ifname 'eth0.2'
	option proto 'dhcp'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
    option device 'switch0'
    option vlan '1'
    option vid '1'
    option ports '2 3 4 0t'

config switch_vlan      
        option device 'switch0'  
        option vlan '40'       
        option vid '40' 
        option ports '1 0t'

The issue was on my side with a broken dhcp server. :confused:
This is a working config that makes lan port 4 to a wan port:

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '101'
        option vid '101'
        option ports '0t 1 2 3'

config switch_vlan
        option device 'switch0'
        option vlan '102'
        option vid '102'
        option ports '0t 4'

config interface 'lan'
        option ifname 'eth0.101'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.2.1'
        option netmask '255.255.255.0'
        option stp '1'

config interface 'wan'                                                     
        option proto 'dhcp'                                                
        option ifname 'eth0.102' 
3 Likes

That is a working config with 4.19 kernel. Is there already a solution for 5.4 kernel?

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.