Fritz!Box 7520 modem test, ISP config, and other questions

Hi,

I finally installed OpenWRT on a Fritz!Box 7520 according to the official installation guide and also followed the steps for installing the DSL modem.

I only have cable internet as of now and no DSL, but will get DSL hopefully in a week or so. Is there some way I can test/ensure, that the DSL modem actually works, before getting a DSL connection?

If there is no self-test available, I could go to a friend's house and use his 1und1 (Germany) DSL connection, but might need further help with this.

I am mainly asking because of this:

  • Some models of the 7530/7520 require an additional patch to enable the VDSL modem which is not yet included in any build. Affected devices can be recognized by the message vrx518 0000:01:00.0: dc_ep_clk_on failed in the kernel log.

I didn't see this kernel log message in OpenWRT's Luci interface kernel log, but I still want to make sure that DSL modem actually works. Or should I have checked the kernel log message in FritzOS, before flashing?

The documentation regarding accessing internet connection is quite overwhelming for a newcomer to networking. It is going to be DSL 100 via German Telekom. I read the ISP configuration guide, but don't know where to put this configuration. Can anyone explain to me what I have to do to get internet working, once DSL is available?

In the meanwhile, until DSL is available, how can I get internet via the OpenWRT router by connecting its LAN1 interface to my cable router's/modem's LAN interface (does not offer passthrough, so will be double NAT)?

In the network file in /etc/config.

https://openwrt.org/docs/guide-user/network/wifi/wifiextenders/bridgedap

Use DHCP client instead of static IP, or you'll need to add DNS and gw IPs to the config too.

1 Like

On affected devices, the kernel message appears even without an actual DSL connection. So, if you don't see the message in the log when running OpenWrt, that means you don't have to worry about this particular issue.

By default, the device is already configured for PPPoE on the DSL interface. So, the only thing that is missing for a connection from Deutsche Telekom is the VLAN configuration.

To set it up, just edit the WAN interface and change the device from dsl0 to dsl0.7 (this is possible from the LuCi web interface, you don't need to edit the config file manually).

The PPPoE username and password doesn't matter, unless you have disabled "Easy Login" in the Telekom Kundencenter. Maybe you still have to enter some value though (just pick something).

1 Like

I made a few changes in config files and in LuCI. After the latter, I couldn't reach the webinterface and it told me that it reverts back these. I waited a long time, but still couldn't connect via SSH or LuCI. Had to do a factory reset to get it working again. What could be the reason that LuCI's reverting back did not work as intended? Could this also mean that there is some hardware defect?

Thx. That sounds easier than the ISP configuration help page. Hopefully this works.

Quick feedback: Got internet working. Yay! Thx for the advice with dsl0.7. Needed PPPoE login data to get it working. The only difficulty was to get the PAP/CHAP username right, which can be found here (German): https://telekomhilft.telekom.de/t5/Festnetz-Internet/PPPOE-Einwahl-ueber-einen-Router-herstellen/ta-p/3654990