[fritz!box 7412] [wifi] wps_start method implemented?


Since today I run OpenWRT 21.02.1 on my Fritz!Box 7412.

When I execute
ubus -S call hostapd.wlan0 wps_start ; echo $?
i get exit code 3.
Does that mean, that the wps_start method is not implemented?

How can I get WPS with OpenWRT?
The original fw could do it, but it refused to change its default route, because of its branding (by a german ISP).


afaik hostapd-utils needs to be installed for that.

uhm... isn't ubus part of that package? i mean: isn't it already installed with OpenWRT 21.02.1?
i used this image: from 2021-10-26.

should i try today's snapshot?

with hostapd-utils (re-)installed i still get exit code 3... where i need 0... i guess... right?

i got this:

root@elliot:~# opkg install /tmp/hostapd-utils_2020-06-08-5a8b3662-38_mips_24kc.ipk 
Installing hostapd-utils (2020-06-08-5a8b3662-38) to root...
Configuring hostapd-utils.
root@elliot:~# ubus -S call hostapd.wlan0 wps_start ; echo $?

now i try the snapshot...

the snapshot is lacking the wireless (AR9287) firmware... it seems like it is contained in no package...
even the imagebuilder doesnt install it... lol

root@elliot:~# opkg search /lib/firmware/ath9k-eeprom-pci-0000\:01\:00.0.bin 

the ath9k firmware is created by some script at startup, when i install that image that imagebuilder made me...
but that ubus command still exits with 3.

now i removed wpad-basic-wolfssl and installed wpa-supplicant & wpa-cli & hostapd & hostapd-utils
and get exit code 8 (that is UBUS_STATUS_NOT_SUPPORTED... right?).
it seems like the output of
ubus -S list wpa_supplicant.*
should not be empty... but it is...

how can i change that?

WPS can be enabled like described here:


  1. install loday's snapshot
  2. add option wps_pushbutton '1' to the AP config in /etc/config/wireless (that can be done in luci possibly... maybe i overlooked it and steps 3 to 5 are not necessary... :slight_smile: )
  3. run opkg remove wpad-basic-wolfssl
  4. run opkg install wpad hostapd-utils
  5. reboot
  6. the WPS button on the back should work... :partying_face:

is there any disadvantage?
i mean why were wpad and hostapd-utils not installed?

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.