Fritz!Box 4040 VQ - VLAN Ethernet not working

Hey guys!

I replaced my old TP-Link 841N with Fritz!Box 4040. I have problems and meanwhile no idea whats wrong with my config.

I install OpenWrt 19.07.4 r11208-ce6496d796 on my Fritz!Box.

Problem: VLAN doesn't work on the ethernet ports. On WiFi it works!

My setup:
LAN1 is the trunked port with VLAN20 and 99 from my core router.
LAN2, 3: untagged VLAN20
LAN4: untagged VLAN99

First Wifi untagged on VLAN20 and it works.
Second Wifi untagged on VLAN99 and it works.

But the LAN Ports 2, 3 (untagged VLAN20) and 4 (untagged VLAN99) are not working.
tcpdump (run on a device which is connected to one of these ports) shows no packet from the Fritz!Box.


config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd31:7b49:1fe0::/48'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '99'
        option vid '99'
        option ports '0t 1t 4'

config switch_vlan
        option device 'switch0'
        option vlan '20'
        option vid '20'
        option ports '0t 1t 2 3'

config interface 'lan'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.88.248'
        option gateway '192.168.88.254'
        list dns '192.168.88.254'
        option ifname 'eth0.20'
        option broadcast '192.168.88.255'

config interface 'Ios'
        option proto 'static'
        option type 'bridge'
        option ipaddr '192.168.99.253'
        option gateway '192.168.99.254'
        list dns '192.168.99.254'
        option netmask '255.255.255.0'
        option broadcast '192.168.99.255'
        option ifname 'eth0.99'

What I doing wrong?

There's a bug (well, it's more complex than that but...) in .4 and you should either avoid this particular version or rebuild it with the offending commit reverted.

1 Like

Thanks for the hint. I'll try a downgrade to [19.07.3]. But not yet. My doughter will kill me if I terminate the Internet :upside_down_face:

Well ... it's working now!

Thank you very much!

1 Like

Glad to hear that.
Please mark the solution (there's a tickbox for that next to each answer) and edit the title to add "[solved]" (little pencil icon next to the title)

There is no pencil icon next to the title in my first post. Only at the next.

Checkout this guide, it has pictures.
If it still doesn't work, it might be that being a new user you do not yet have the authorization to edit titles (no, I'm not sure, this is just a shot in the dark)