Fritz!Box 4040 [Solved]

I can't install openwrt firmware, i try to install via update page by uploading the .bin but it showing error 5. Can't connect via SSH. Someone can help me ?

The page for that device looks reasonably complete

Where are you stuck?

1 Like

The device page does not instruct you to do that. You are supposed to use a temporary FTP server running at boot.

$ ftp -n -v -p
Connected to (
220 ADAM2 FTP Server ready
ftp> quote USER adam2
331 Password required for adam2
ftp> quote PASS adam2
230 User adam2 successfully logged in
ftp> quote MEDIA FLSH
200 Media set to MEDIA_FLASH
ftp> binary
200 Type set to BINARY
ftp> put openwrt-18.06.1-ipq40xx-avm_fritzbox-4040-squashfs-eva.bin mtd1
local: openwrt-18.06.1-ipq40xx-avm_fritzbox-4040-squashfs-eva.bin remote: mtd1
227 Entering Passive Mode (192,168,178,1,12,0)
150 Opening BINARY data connection
226 Transfer complete
5505028 bytes sent in 24,7 secs (223,21 Kbytes/sec)
ftp> quote check mtd1
150 Flash check 0x9F288C3D

Hello guys,

So i'm stuck in that line :

quote MEDIA FLSH ( command not found )
So I just bypass it

ftp > binary : ok
after I make a dir to the usb Key plugged in the box

when i make a dir to go to usb root
but when i make a ls .bin file is present
but when I make a put .bin file it return "File not found"


Connecté à
220 FRITZ!Box4040 FTP server ready.
530 Please login with USER and PASS.
Utilisateur ( : sharujan
331 Password required for sharujan.
Mot de passe :
230 User sharujan logged in.
ftp> quote MEDIA FLSH
500 'MEDIA FLSH': command not understood.
ftp> binary
200 Type set to I.
ftp> dir
200 PORT command sucessful.
150 Opening ASCII mode data connection for '/bin/ls -lgA'.
dr-xr-xr-x 3 ftp ftp 60 Jan  7 22:21 FRITZ
dr-xr-xr-x 1 ftp ftp 56 Jan  7 22:02 General-UDisk-01
226 Transfer complete.
ftp : 102 octets reçus en 0.00 secondes à 51.00 Ko/s.
ftp> cd General-UDisk-01
250 CWD command successful.
ftp> ls
200 PORT command sucessful.
150 Opening ASCII mode data connection for 'file list'.
FRITZ.Box 4040 155.07.01i_07.01.19_2145.export
System Volume Information
226 Transfer complete.
ftp : 323 octets reçus en 0.01 secondes à 53.83 Ko/s.
ftp> put openwrt-18.06.1-ipq40xx-avm_fritzbox-4040-squashfs-eva.bin mtd1
openwrt-18.06.1-ipq40xx-avm_fritzbox-4040-squashfs-eva.bin: Fichier introuvable

Maybe try adam2 as username and password?

Connecté à
220 FRITZ!Box4040 FTP server ready.
530 Please login with USER and PASS.
Utilisateur ( : adam2
331 Password required for adam2.
Mot de passe :
530 Login incorrect.
Échec de l’identification.

Already Tried, not working. :confounded:

The bootloader is not active, the box is running normally.

1 Like

You right, I will try again this night. Thx You !

So, not working with windows DOS, I will use winSCP command line.

I had a similar issue because I tried the windows builtin ftp client.
This client does NOT support the passive mode.
Download a windows port of the gnu ftp client, that did the trick for me and my FB-4040.


1 Like

Thank you ! I successfully via Kali linux ! Thx u guys

1 Like

@sharujan If your problem is solved, please consider marking this topic as [Solved]. (Click the pencil behind the topic...)

Thanks for the advices.

I have had the same problem in windows 10.

The device documentation in openWRT wiki does not explain it wait for windows users.

ftp command in windows does not have '-p' option, nor passive command.

But you can use 'quote pasv' to get passive mode.
Anyway using ftp in windows does not work.

WinSCP was of no help for me, either.

I used WSL (Windows subsystem for Linux)]
and a Debian Linux minimal shell install from windows store in order to get a bash shell workding under Windows (here is how to install it and get it working).

Once installed, I run the shell program and inside the shell window I installed the ftp package (as the basic linux shell installed does not have ftp):

apt install ftp

Then I copied the openWRT firmware in c:\openwrt.bin and in the linux shell I used the commands from the instructions in the device page, copying the file from c:\openwrt.bin to the device:

ftp -n -p quote USER adam2 quote PASS adam2 quote MEDIA FLSH binary put /mnt/c/openwrt.bin mtd1 quote check mtd1

After the put I did not receive the messages about bytes sent, and it took a while for the device to reinit, and there were quite a lot led flashing.
But it rooted correctly and I had openwrt running and accesible in (remember to change de IP in your PC to, or better configure two IPs and

One problem I had too was to guess when to run exactly the ftp command. If you wait too much, you receive an error. From the instructions I have thought it was after the initial slow flashes of the power led.

But you have to run it when you see the first flashing in the power led.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.