Fritz 7530 doesn't pull from TFTP

This is making me CRAZY since 2 days.
I'm following the official instructions of the device page, first I tried on Linux, I run eva_ramboot and it succeeds, the I get stuck at this step:

  • The U-Boot will now start. Now assign yourself the IP address Copy the OpenWrt initramfs (!) image to a installed TFTP server root directory on our Computer and rename it to FRITZ7530.bin.

  • The Box will now put the file (a pull request every 5 seconds) and boot OpenWrt into RAM. This can take up to two minutes.

I do the first step, but the Box seems to do nothing forever. No pull. I retried many times, reassigning my IP, restarting the tftp service (tftp-hpa) but nothing.

So I try to restart the installation with a Windows 7.
Eva_ramboot succeeds, I change my ip to, I start tftp64, choose the right interface... and nothing again. No signs of life from the Box.

I want to specify that I carefully followed the steps from the official guide and also from here.

Another thing, I'm trying to install openwrt v. 23.05.0-rc1 because I need the modem functionalities. The uboot file is from this folder. I also tried the snapshot uboot.

Last thing, the Box is correctly working. If I reboot it I can get to the official Fritz login page.

I now tried the images and uboot from snapshot, no luck. I also tried the 32bit version of TFTP64 on windows, as suggested in another post. Still no TFTP pull.
When I use eva_ramboot, the only difference I see from here is "MEDIA SDRAM7" , to me it writes "MEDIA SDRAM".

I'm clueless now, I guess it's another hardware revision? I took photos of my pcb and the chip brands look the same of the photos posted on the wiki, I don't know about the model.

Is your client's firewall down or allowing that specific connection? That's often an issue here on my end. Once the firewall gets disabled all of a sudden things start to work :innocent:. Or you could allow the FritzBox's IP in your firewall.

Firewall is down both on Linux and Windows.

Can you attach serial console to see what's going on? There have been reports of unsupported and/or broken flash chips recently.

I don't have it so I'll need to buy an adapter. I found the 4 holes, could you tell me in the meanwhile the order of ground, tx, rx? Or I'll need to buy also a multimeter...

IIRC, the pinout of the 4040 is the same:

If you look closely, you can identify GND as the one having 4 connections to the GND plane on the PCB.

Looking at the back of the 7530 PCB, it seems that GND matches:

1 Like

I'm new to this, I really don't see what you mean in the photo.
Also, what about the voltage needed? Is it reported somewhere?

It's easier to see what I mean in the first picture of this website:

There are 4 holes in the center, the upper right has three connections to the ground plane. It's usually straight forward to identify GND this way on the PCB.

The logic level is 3.3V, be sure to only connect GND, Tx and Rx. VCC is left unconnected!

1 Like

Perfect! Thanks for the explanation!

Well I tried the procedure with a different computer and it worked perfectly at first try... I can't believe how much time I wasted with this.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.