Fresh Install - NO WAN - Please help

Just bought a shiny new Linksys WRT1900ACS v2, and figured out how to flash it with openwrt.

Got my wireless set up etc., but NO INTERNET? I've tried everything as far as configuring my WAN interface. I checked my old router and all I did there was set it to DHCP Client and bam - all good. What gives?

Things I've tried so far are insuring my firewall and DNS are all set right - I followed this guy's page on Internet Access about half way down this page - That was already all set up correct.

I've rebooted the cable modem a few times, once I powered everything off for a half hour, thinking it would get a new IP from my ISP, etc. Nada.

I tried setting the WAN settings I get from my old modem (which gets them via dhcp) manually by setting mine to static and typing it all in there. No go.

Not sure what I can send that would help y'all to help me. maybe a screenshot of my WAN/LAN interfaces? I also can't have that new modem on and have my internet access on at the same time, so this is going to be slow going, switching back and forth to troubleshoot.

Hope someone can point me to a quick start of a fresh install. I can't believe a fresh install can't just grab an IP from my cable modem..which is a arris surfboard modem sb6183 for what that's worth.

I guess I should have made a left turn in Albuquerque.


The default configuration should work out of the box... unless the modem is tied to the specific MAC address of the modem.

As a simple test, wire the WAN port from your new WRT1900 to a LAN port on your old router and confirm internet access is working with default openwrt settings.

Make sure old and new routers are using different subnets on their LAN interfaces with above test.
eg. change default LAN IP on openwrt router to say

BILL!! That's a great idea, and it works! Soo...what does this tell us. Let me guess...

My cable modem sucks? Uhh...why the heck can I grab an IP from my old router but not my cable modem? Is there some linuxified way I can force it? Gotta get that old router replaced.

Yet another reason your idea rocks is, now I can have both up and running so I can troubleshoot while maintaining an internet connection.

Thanks mang! So far so good. Next, openvpn install so I can vpn the whole LAN, my number one reason for going this route...

Was the old router supplied by your ISP ?

As suggested by @eduperez , try cloning the MAC address of the WAN port of your old router onto WRT1900ACS.

LuCI > Network > Interfaces > WAN > Edit > Advanced Settings > Override MAC address

Have you examined the system log for error messages?


You might try connecting the new router to the modem and then powercycling the modem. It may accept the new device at its own boot time. (At least that advice can be found when googling for modem mac lock...


Cloned MAC to no avail. Rebooted both modem/router in varying order and up to 15 minutes of downtime, nada. The only way this new router will get it's WAN's interface to get an IP, is if I daisy chain it to my old router. There's got to be a fix.

I'm thinking I should try a new cable modem, and see if that solves the issue - this will involve me having to call my ISP, they 'lock' in their service to my modem's MAC addy. So, probably have to wait till next week to try that.

Any other ideas to force my modem to dish out an IP for my new WAN interface? I did find out how to get into the cable modem's GUI, but it's basically a read-only view of some basic settings, not much power to do much there.

I'm out of ideas. Dad gum it. Sup doc?

Is this strictly a cable modem OR cable modem/router combo?

Check that the old router is configured as a DHCP client and nothing else (VLAN, for example). If that fails, I would try to watch the logs, then use "tcpdump" to see what is happening.

Some suggestions:

What does system log report? LuCI > Status > System log

Did you previously try using your WRT1900 with linksys OEM firmware to connect to your ISP to verify it worked out of the box before flashing it with OpenWrt?

What version of OpenWrt is installed?

Plug a computer directly into the cable modem's ethernet socket and confirm whether it can get internet access with default DHCP settings. Don't forget to power cycle the modem.

Here's a silly idea. Put an unmanaged switch between the cable modem and WRT1900acs's WAN port. If you don't have one handy, perhaps use two LAN ports on your old router but make sure you turn off DHCP server on old router !

First, thanks for all you guys help, it's good to know there's good support out there! It's also part of why I decided to stick with it and avoid dd-wrt, I've read so much about how openwrt is better.

Soo...after much hair pulling and gnashing of teeth, I finally just got a slightly different model router (WRT3200ACM ) AND a new cable modem, since I also noticed it was dropping it's 'learned' mac addy's of the router(s)...and bingo, got openwrt up and running in no time. Just wrapped it up today, even got openvpn installed on the router and my entire LAN is tunneling out to a foreign country. FTW!

So, mark this one solved or closed, I'll open a new thread if I ever run into any problems in the future. But, so far it's rock solid and purring like a kitty, barely above an idle. I'm so excited! :smiley:


You can mark the issue as solved yourself, there is a button on the bottom of this page.

1 Like

Au contrair mon cheri. Perhaps I'm too new to this site, but I'm not seeing a button to mark solved. No worries though.

You have to "open" the menu by pressing on the "..." option at the bottom of each post... mon amour.

ahhh, I see said the blind man... Solved! Many thanks! About to open a new topic - how to 'turn off' my openvpn tunnel w/o breaking everything. :smiley:

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.