French Red-by-SFR ISP xDSL configuration

Dear community,

I configured my OpenWRT modem to connect to my ISP by xDSL.
My ISP is french. It is called Red-by-SFR.

I couldn't find exactly the settings I was looking for as discussions on the internet mostly concern FTTH. I have xDSL though.

Anyhow, those settings allowed my modem to connect:

config interface 'wan'
	option proto 'pppoe'
	option username '1A2B3C4D5E6F@neufpnp'
	option password 'neufpnp'

...where 1A2B3C4D5E6F is the original NB6VAC SFR Box MAC address in capitals without double points.

It works... kind of:
I get this IP address 77.130.206.15 and my internet gateway address is 77.130.206.1, whereas with the original NB6VAC SFR Box I had this IP address 81.14.32.103 and this internet gateway address 81.14.32.1. (I also noticed that 81.14.32.103 was always the same, whereas 77.130.206.15 is changing from connection to connection.)

On the internet I read to set option vendorid 'neufbox_NB6V-MAIN-xxxxxxx_yyyyyyyyy' for the FTTH connections. I tried it with my xDSL connection but it didn't change a thing.
I also forced the MAC address of the wan device to be the one of the username, just in case:

config device 'wan_dsl0_dev'
        option macaddr '1a:2b:3c:4d:5e:6f'

But still I didn't obtain 81.14.32.1 as I was expecting.

Thus my question:
How to fool completely my ISP in order to make him think I am connected to the internet with my original NB6VAC SFR Box?

Thanks for your assistance.

FWIW i must clone my isp modem mac in the wan interface not in the dsl0 interface:

config interface 'wan'
        ...
        option macaddr 'XX:XX:XX:XX:XX:XX'
        ...

Thank you!
I am confused because option macaddr was located under config device 'wan_dsl0_dev' at first when automatically set by OpenWRT.
Anyhow I have made the correction you pointed out. Now my network file looks like:

config atm-bridge 'atm'
	option nameprefix 'dsl'
	option vci '35'
	option vpi '8'
	option encaps 'llc'
	option payload 'bridged'

config dsl 'dsl'
	option ds_snr_offset '0'
	option annex 'a'

config interface 'wan'
	option ifname 'dsl0'
	option proto 'pppoe'
	option username 'XXXXXXXXXXXX@neufpnp'
	option password 'neufpnp'
	option vendorid 'neufbox_NB6V-MAIN-xxxxxxx_yyyyyyyyy'
	option macaddr 'xx:xx:xx:xx:xx:xx'
	option ipv6 '0'
	option peerdns '0'
	list dns '1.1.1.1'
	list dns '1.0.0.1'

config device 'wan_dsl0_dev'
	option name 'dsl0'

...but still, when connected I get a 77.130... IP address...

i'm sorry was just sharing my personal experience.

you can put mac address in both wan and/or dsl0 with your pppoe configuration wont make much of a differece.. the vendor class usually is for dhcp connections.. maybe your provider box is using some other mac for connection and you need to do some spoofing wireshark or similar.

do you need to obtain a specific fixed ip address assigned to you by your provider? if so you could just put that in your wan configuration.

Thank you so much @jesanor!

Good to know that the MAC address can be put in both places.
Indeed I will remove the vendor class as it is intended for FTTH which works by DHCP on that SFR Box.

I would like to do some spoofing with wireshark but I am quite new to it.

  • On my OpenWrt modem+router can I do something like tcpdump -i wan -w file.pcap?
  • With my SFR Box, what kind of equipment do I need to insert between the Box and the cable? (Fortunately it is a standard RJ45 interface on that side, and a RJ11 interface on the side of the wall.)

I don't really need to obtain a fixed IP address, as I use reverse DNS to reach my home server. My goal was more to mimic my original SFR Box as much as possible. Do I set a fixed IP to my WAN with option ipaddr '81.14.32.103' under config interface 'wan'?

Thanks,

maybe just an overhead? you can just leave all mac address to default value and if connection works as with provider box (same speed etc.) u'r good to go. clone mac only if you cannot connect or have different speed or other issues, just my 2 cents here.

yes but if it is not a static ip address assigned to you by your provider i wouldn't do that :slight_smile: also for ip address could be a matter of lease duration on provider box, maybe you need to wait for expire.. but every provider is different i'm just guessing here sorry.

for other matters (wireshark, etc) maybe some other user can help you out here.. let's see if someone else have some other suggestion for you :thinking:

Thanks :+1:

Hey. Just wanted to add some things for future reference, as I'm also trying to connect via xDSL using Red-by-SFR.

First, you can download, in plain text, the config file that SFR servers automatically send to their modems. a simple wget with url 'http://ncdn.nb4dsl.neufbox.neuf.fr/nb6v_Version%203.5.8/NB6V-CONFIG-R3.5.8.0' should do it. In it you can see that port 1287 is used for telnet and port 1288 for ssh (there is also some fun stuff at the end of the file).

Also, when typing 'telnet 192.168.1.1 1287', the modem just sends a big unreadable string and closes the connection. This string is actually made of small strings of the form '<number with two hexadecimal digits>=<some information>;' where the right hand side is either a number or a string. I guess you can get quite a lot of useful information in there (although I don't know what most of it means).

And there's also an API to communicate directly with the modem. There is a (quite old) documentation about it, which can be downloaded here : https://lafibre.info/images/altice/201207_sfr_api-rest.pdf

Really interesting post! Thanks.
I will try to play a bit with the REST API.
Please tell us more about your OpenWrt settings once you are connected to Red-by-SFR via xDLS.

@sebi5361
when you use the RED box, can you see if your wan connection is PPPOE or DHCP ?
i guess, there are 2 different DHCP servers, one for PPPOE and another one for DHCP. This could be the reason why you don't get the same IP as you're using PPPOE in your openwrt settings.
If you can configure a DHCP connection in Openwrt it may fix your issue.
I have a fiber connection with RED and i get the same IP as my BOX, i didn't even change my MAC address.