Found DDNS Luci bug

ddns works fine
luci interface for it too.

but if you go system -> software
and update lists

after that if you swich to sevices -> ddns
you get this

/usr/lib/lua/luci/controller/ddns.lua:116: attempt to index field '?' (a nil value)
stack traceback:
	/usr/lib/lua/luci/controller/ddns.lua:116: in function 'service_version'
	/usr/lib/lua/luci/controller/ddns.lua:126: in function 'service_ok'
	/usr/lib/lua/luci/model/cbi/ddns/overview.lua:20: in function 'func'
	/usr/lib/lua/luci/cbi.lua:66: in function 'load'
	/usr/lib/lua/luci/dispatcher.lua:1340: in function '_cbi'
	/usr/lib/lua/luci/dispatcher.lua:1023: in function 'dispatch'
	/usr/lib/lua/luci/dispatcher.lua:478: in function </usr/lib/lua/luci/dispatcher.lua:477>

only after reboot it get fixed

openwrt 19.07.03

Have you cleared your Browser Cache and the LUCI Cache??

1 Like

Does the problem persist with 19.07.4?

3 Likes

why I should every time clean cache to switch page in webinterface ?

If it was permanent then it maybe has reason to do

but as I said after restarting openWRT
it works
until next time you go system -> software
and update lists

:slight_smile:

have not updated yet to 19.07.4

Reason I asked is because everything is now rendered client side, so the chances are when you flipped over it was loading a cached version of the page.

A simple test is to press Ctrl+Shift+R which will clear the cache for said page your loading. OpenWRT has had many changes which filter from snapshot to service builds after time.

I am also ready for 19.07.4 from 19.07.3 it's just a step if you have issues though.

4 Likes

If we're talking about luci-app-ddns, ddns-scripts, I've never run into this issue before. Trying the same steps as armars374 makes the page load normally on 19.07.3 and 19.07.4.

Try listing what ddns* packages you have installed, and maybe your ddns configuration file (sanitized, passwords/domains removed or renamed). Maybe a specific combination is to blame.

ok thank you

Ctrl+Shift+R
in which browser ??

in opera it does nothing

currently I am away from that router
near few days I can not get detailed info

With this step, Lua usage in LuCI is reduced and LuCI effectively comes closer to the goals of the experimental LuCI2 without having to rewrite everything from scratch.

but as I understood about what you wrote
is in 19.07.4

maybe I am wrong

Did you check the change log for the DDNS application?.

The issue can arise when there is major changes to the application not just to LUCI.

1 Like

as I know DDNS is script (.sh)

However the Option in LUCI aka the WebGUI is a LUCI App hence it's opkg being called luci-app-ddns.

where to find changelog for ddns ??

GitHub.

Or directly to the app In Question

I have just tried this exact thing on 19.07.4 and did not see any problems at all.

2 Likes

looks like someones been using opkg upgrade... ( or similar manual package operations )

2 Likes

I get that too and tried another clean browser. I have 19.07.4. I see that it appears randomly.

1 Like

In some browsers, this command is CTRL+F5.

1 Like