Forwarded ports show as 'Stealthed' and not visible

Does QoS have any impact on port forwarding?

should i just ping? what do you suggest to check this?

This is a problem!! Change input and forward to reject. Do this immediately.

1 Like

No, ping won't verify this. You need your game (or whatever service) to be running and ready to accept connections. And the best way to test is to use another device (inside the network) to connect to that service.

Or use a port scanning app from a device on your internal network to look to see if port 7777 is listed as open on that host.

I just booted up the game and connected internally just fine. I was able to find the service on LAN

with the game running, you can run a port scan from a website. But you might also just want to ask someone who also uses that game to try to connect to your game server.

1 Like

I know it wont work because doesn't see the port as open. It immediately responds as closed.

ShieldsUp! reports it is stealthed

Some scanners don't always produce accurate results. And some services don't actually respond anyway (Wireguard. for example, doesn't respond at all, unless you have the correct cryptographic keys).

That is why it is worth actually trying a real connection from a game. You may be right that it could fail, but worth trying.

So I had my brother connect his PC to a hotspot to try this out, and all he can see is my Host's internal IP with the port after it. The public IP isn't on there, and of course he is unable to join.
I also had him do a direct connect to the external ip and port and there was no connection. No servers were found at the address.

Motorola got back to me and said that the modem is not blocking any ports (as I thought). So the only thing left here is this router. The host is open, has been working for years. The ISP isn't blocking any ports.
I just opened up some test ports and they are also reporting as 'stealth'. There is no service running behind them, so something is hiding them.
What else is there to try?

Have we tried?
list proto 'icmp'

I just tried adding that to available protocols and it still shows as 'stealth' and the port is not open to the public

This is a PITA! One last toss is to reboot Motorola and router.

Off the reservation and not a solution is ethernet cable to Moto to Game Rig and reassure the OpenWrt Router is culpable of this stingy port stealthing.

Input to Motorola is Coax. So i assume i would try Coax > Modem > ethernet > Host?
Then try to see if someone could join?

Yes. Keep in mind that you may need to reboot your modem so that it will supply an IP address to your computer. And also, that IP address may not be the same as you've been seeing on the WAN of your router -- so check the IP you get on your PC.

I contacted xFinity again just in case and they do not block ports for people.

Another ugly tidbit is the yougetsignal shows me on a different continent and IP as GRC.

So I did what you recommended and restarted my Modem to get a new public IP. I did get a new public IP. I attempted to connect to the game service with another PC on hotspot and it had same results.
I tried ShieldsUp! and yougetsignal and it yielded stealth/closed.
I tried completely disabling my firewall and it yielded CLOSED port on ShieldsUp! and yougetsignal.

I am beyond confused. I had a PC with no firewall and it still couldn't be seen publically.

I have reached maximum number of replies for the past 24 hours. Further replies will need to be edits

Does the IP reported by ShieldsUp match what you see on your PC's network connection info (when directly connected to the cable modem)? Is the game up and running (fully active and ready for play) when you run the test?

Yes to both.

There is no rule created for the DNAT.
From what I see you are running 22.03, which uses nftables, so try with nft list table nat -a

root@FriendlyWrt:~# nft list table nat -a
Error: syntax error, options must be specified before commands
nft list table nat -a
   ^               ~~

Do you have another computer you can use (such as a Mac or a linux machine, even just a raspberry pi) where you can turn on a server (web server, for example) to test a direct connection to that?

Whats something easy to setup? What port?

A web server on a linux box or pi... doesn't matter what it is serving, as long as it works. port 80 is the standard web port (http).

I tried creating another game server on a different PC. as well as creating a minecraft server w/ port forwarding. Neither showed open ports on website tools or let me connect to them via game client.

Does the IP reported by ShieldsUp match what you see on your PC's network connection info (when directly connected to the cable modem)? Is the game up and running (fully active and ready for play) when you run the test?

1 Like