Former Zeroshell User running OpenWRT x86_64 on VMware - Gotchas?

With Zeroshell no longer maintained and DD-WRT not working quite right, I tried this. I got the v21 x86_64 version running on ESXi 7.0 as a virtual machine. Even managed to expand the disk to 2 GB so it had room to install open-vm-tools. So far, so good, but I haven't tried putting it into production.

Among the gotchas I ran into so far:

  • Had to use an IDE interface for the disk as IDE controller 0, master (hda), as it didn't recognize SATA or SCSI.
  • Used a Windows VM to restore the .img to a virtual disk, then System Rescue to enlarge the volume on the disk. I managed to resize it to 2 GB.
  • Like DD-WRT it uses a bridge (br0) instead of one of the NICs (eth0, eth1) but, unlike DD-WRT, it actually answered HTTP and SSH on the bridge.
  • VMware Client still won't let me edit NIC status on the fly.
  • ESXi 7.0 doesn't have an option for "Other Linux 5.x" so it complains the VM settings are incorrect.

The x64 version seems to like vmxnet3, so 10 Gbit is doable. Both E1000 and E1000e are usable.

Any other gotchas I should watch out for?