Forced separation of internet connection => Solution for reconnection

What I said in the beginning: It`s a Turris Omnia Router but they based on OpenWRT.

You're using a german keyboard, right? :wink:
The backtick character has a special meaning in the forum markup and that's why the text you write comes with different fonts and missing apostrophes :slight_smile:

The IPV6 is probably harmless: I'm using a tunnel because my ISP has poor IPV6 service (LOL, they call it "experimental", must be some sort of marketspeak for shit!)

They are based, but we don't support them.
You can either switch to OpenWrt or ask here for help.

1 Like

OK, thanks a lot for your support.

1 Like

The issue is with the PPPoE authentication process and that might be caused by something on the ISP's back-end.

The ppp instance on the router is issuing a SIGTERM (for unknown reason) signal

If you want to try to debug the matter it would require to alter /etc/ppp/options and add

kdebug 7

also try with the ppp options (same file)

maxfail 0

The final process arguments pppd is running with can be queried with ps -aux | grep pppd - :warning: you may want to obfuscate potentially private data such as username | password

For verbose debug output in the logs of netifd it would require to edit /etc/init.d/network

modify procd_set_param command /sbin/netifd by adding -l 5, it should read then

procd_set_param command /sbin/netifd -l 5

and add below that line

procd_set_param stderr 1

Once done/set execute service network restart ; logread -f

1 Like


through /lib/netifd/proto/ is seems that ppp arguments set in /etc/ppp/options are discarded/neglected. Arguments should therefore be set through option pppd_options in /etc/config/network (but not all such available arguments are working through the UCI parser).

And then

which might cause issues with netifd's supervisory role.

Did you ever try

in the WAN section of /etc/config/network ?

Sorry for the delay.
I've switch to the Turris Forum and there is under the following link in thread an workaround available:

Turris Forum