Force 160MHz on Wireless AP client

Hello.

I have at home a Fritz.box 7590 that is spreading the wifi5 across the house. I use channel 112 and 160 MHz.

I configured 2 wireless client (EA8300 with openwrt) that collect the wifi and repeat the network over the LAN ports.

EDIT: I made a mistake, it's not a EA8300, it's a Linksys EA7300 v2.

The issue I see is that the wifi that they collect is 80 MHz, not 160.

Is there any specific setting I have to do to force the 160MHz? I tried in every way, but I get only the 80 MHz.

Thank you :slight_smile:

EA8300 hardware only have 80 MHz width whatever interface you are using.

ipq4019 specs

qca9886 specs

I realize I made a mistake, is a Linksys EA7300 v2. Apologize for the error (I went by heart).

In the menu I can see the 160 MHz, are these not working?

Ok.
I also have experience with the EA7300v2, I remember trying 160 MHz with no success. I didn't push further as I don't own the device.

What does iw reg get return?

This is the reply:

root@OpenWrtLinksys:~# iw reg get
global
country IT: DFS-ETSI
        (2400 - 2483 @ 40), (N/A, 20), (N/A)
        (5150 - 5250 @ 80), (N/A, 23), (N/A), NO-OUTDOOR, AUTO-BW
        (5250 - 5350 @ 80), (N/A, 20), (0 ms), NO-OUTDOOR, DFS, AUTO-BW
        (5470 - 5725 @ 160), (N/A, 26), (0 ms), DFS
        (5725 - 5875 @ 80), (N/A, 13), (N/A)
        (5945 - 6425 @ 160), (N/A, 23), (N/A), NO-OUTDOOR
        (57000 - 66000 @ 2160), (N/A, 40), (N/A)

root@OpenWrtLinksys:~#

Try channel 100.

1 Like

I will visit home in 1 month, I will try 100 for sure on the Fritz.box. But isn't 100 and 112 be part of the group for the 160 MHz?

1 Like

It should be, but you never know if that won’t nudge the wifi driver to enable 160 width. Also ensure you have up to date OpenWrt.

I will do the configuration again once home :slight_smile:

Thank you!