Followed guide, but

I followed the above. I'm using BT FTTC with HH5a and my config is


config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd15:93aa:3d35::/48'

config atm-bridge 'atm'
	option vpi '1'
	option vci '32'
	option encaps 'llc'
	option payload 'bridged'
	option nameprefix 'dsl'

config dsl 'dsl'
	option annex 'b'
	option tone 'a'
	option xfer_mode 'ptm'
	option line_mode 'vdsl'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.2.1'

config device 'lan_dev'
	option name 'eth0.1'
	option macaddr '40:f2:01:48:99:d4'

config interface 'wan'
	option proto 'pppoe'
	option ifname 'ptm0.101'
	option pppd_options 'debug'
	option username 'bthomehub@btbroadband.com'
	option password ' '
	option ipv6 '1'
	option mtu '1500'

config device 'wan_dev'
	option name 'dsl0'
	option macaddr '40:f2:01:48:99:d5'

config interface 'wan6'
	option ifname '@wan'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 4 6t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '5 6t'

config interface 'guest'
	option proto 'static'
	option ipaddr '192.168.3.1'
	option netmask '255.255.255.0'


DSL looks good and is as follows

ATU-C Vendor ID:                          Broadcom 192.28
ATU-C System Vendor ID:                   Broadcom
Chipset:                                  Lantiq-VRX200
Firmware Version:                         5.7.9.9.0.6
API Version:                              4.17.18.6
XTSE Capabilities:                        0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x2
Annex:                                    B
Line Mode:                                G.993.2 (VDSL2)
Profile:                                  17a
Line State:                               UP [0x801: showtime_tc_sync]
Forward Error Correction Seconds (FECS):  Near: 0 / Far: 5976
Errored seconds (ES):                     Near: 0 / Far: 209
Severely Errored Seconds (SES):           Near: 0 / Far: 2
Loss of Signal Seconds (LOSS):            Near: 0 / Far: 0
Unavailable Seconds (UAS):                Near: 30 / Far: 30
Header Error Code Errors (HEC):           Near: 0 / Far: 0
Non Pre-emtive CRC errors (CRC_P):        Near: 0 / Far: 0
Pre-emtive CRC errors (CRCP_P):           Near: 0 / Far: 0
Power Management Mode:                    L0 - Synchronized
Latency [Interleave Delay]:               0.44 ms [Fast]   0.0 ms [Fast]
Data Rate:                                Down: 31.983 Mb/s / Up: 6.364 Mb/s
Line Attenuation (LATN):                  Down: 25.9 dB / Up: 26.4 dB
Signal Attenuation (SATN):                Down: 23.5 dB / Up: 26.5 dB
Noise Margin (SNR):                       Down: 6.0 dB / Up: 5.8 dB
Aggregate Transmit Power (ACTATP):        Down: 2.8 dB / Up: 11.2 dB
Max. Attainable Data Rate (ATTNDR):       Down: 32.100 Mb/s / Up: 6.367 Mb/s
Line Uptime Seconds:                      1389
Line Uptime:                              23m 9s

but the WAN will not come up and i can't ping an IP address. What have i got wrong?

If you're running a current version of openwrt, your ifname should be dsl0.101.

1 Like

Thanks. I'm using OpenWrt 18.06.4 r7808-ef686b7292

Thanks so much - all working now. I thought that dsl0.101 thing was specific to just that single version of OpenWrt. I guess i should have tried it :wink: