Floppy disk access using the image builder

Hello everyone,

I am trying to use the image builder to create an x64 image that accesses the floppy, but when I add kmod-floppy to PACKAGES it complains about an install error. It seems strange if that's not included. I don't have a real floppy, of course, but it's a handy way to add config information to a generically built VM.

Is there some way around this without building OpenWrt from scratch?

we could try guessing... but that's going to lengthen the solution time...

sure... install the modules to the running system... ( if they are available )

1 Like

Apologies. Here is the command:

make image PACKAGES="hostapd openssh-server kmod-floppy"

And here is the error

Collected errors:
 * opkg_install_cmd: Cannot install package kmod-floppy.
make[2]: *** [Makefile:166: package_install] Error 255
make[1]: *** [Makefile:121: _call_image] Error 2
make: *** [Makefile:239: image] Error 2

from a quick look ... i cannot find any kmod-floppy package and it's not built in either... you may need a buildroot for this...

or perhaps request on the mailing list for it to be built into x86/64 hosts... i'd be 50/50 on that... leaning towards building it in... IF disks were not so unreliable these days ) = last 10 years ) ...

but I also used to use these at a time on virtualbox/vmware to move files around... but host based folder mounting etc. have come a long way since then...

It seems strange floppy is not there. Folder mounting has come a long way as you say, OpenWrt now has support for Vmware and Qemu guest tools in the image builder, which is really nice to see (last time I used it was years ago when there was none of this readily available), unfortunately I think VirtualBox guest tools is still painful to configure needing to be built against the kernel, and TBH I haven't even tried to get that working in OpenWrt, the guide on VirtualBox doesn't seem to go into this.

But for this I can get away without write access, so it seems the 'universal' solution for me is going to be connecting a CDROM ISO instead, which is recognised on /dev/sr0 out of the box. I've created a 1.4MB ISO image and that seems to work OK, just need to add some init script to the root to copy stuff off it automatically. I don't think I'll trouble the devs about this, since I have a work-around.

Thanks!

1 Like

And I am surprised to know there is people still using these nowadays, or even ten years ago...

1 Like

Ironically, it is the very fact they they are not used - by anyone - these days that they become interesting for test scenarios. If you need an out-of-band mechanism to get data to a test machine, and you don't want to use the CD-ROM, hard disk or network that may be part of the test, then floppy drives are an option. It's interesting that the vvfat Qemu driver is still getting worked on. I'd have expected it to be long gone by now.

Obviously my needs are a bit niche, but then again, anyone building their own OpenWrt for x64 is probably a bit niche to begin with.

2 Likes

As I've read this topic I remembered this discussion:

I pretty sure support is dropped since this and I doubt OpenWrt is still actively supporting floppy disk if it is dropped in mainline kernel. It might be that there are fragments left in buildroot.

2 Likes

Fair enough. I saw it in 5.4.85, which is what the image builder built for me yesterday.


Although I'm not a kernel expert, maybe that's just the generic floppy code, and not the parallel floppy controller. After a quick google, I don't even know what the controller driver would be called... FDC? Oh whatever. It's amusing reading the comments on that github link, BTW.
sed -i 's!# CONFIG_BLK_DEV_FD is not set!CONFIG_BLK_DEV_FD=y!g' target/linux/generic/config-5.4

they are very handy when building pxe boot server menus et. al. ...

Well, I have no clue how they are acting. If something is marked as "orphaned" there is usually nobody maintaining it anymore actively. This may include also that there is nobody making sure it is working as intended for ongoing changes in other areas which the code is relying on. If this is the case for a longer period it will get dropped completely after a while.

As far as I remember there were fdutils available to configure and debug a Floppy Drive Controller.

aur/fdutils 5.5-5 (+0 0.00)
    Utilities for the Linux floppy driver, i.e. for formatting extra capacity disks