Flint 2: Network going up and down regularly

I recently added the Flint 2 to be my main wifi router. The distance of signal, speed, and responsiveness is great but the network was dropping every 15 minutes.

I'm running OpenWrt 21.02-SNAPSHOT r15812+1071-46b6ee7ffc

I ran the command: ethtool --set-eee lan1 eee off
now the network doesn't drop every 15 mins but every couple hour or so.
These are my logs when the network dropped every few mins.

[ 2315.484321] br-lan: port 4(lan4) entered disabled state
[ 2315.484846] mt7530 mdio-bus:1f lan4: Link is Down
[ 2317.533938] mt7530 mdio-bus:1f lan4: Link is Up - 10Mbps/Full - flow control rx/tx
[ 2317.541533] br-lan: port 4(lan4) entered blocking state
[ 2317.546757] br-lan: port 4(lan4) entered forwarding state
[ 2338.012750] mt7530 mdio-bus:1f lan4: Link is Down
[ 2338.017589] br-lan: port 4(lan4) entered disabled state
[ 2340.061863] mt7530 mdio-bus:1f lan4: Link is Up - 1Gbps/Full - flow control rx/tx
[ 2340.069374] br-lan: port 4(lan4) entered blocking state
[ 2340.074600] br-lan: port 4(lan4) entered forwarding state
[ 2887.683838] mtk_soc_eth 15100000.ethernet eth1: Link is Down
[ 2888.085551] mtk_soc_eth 15100000.ethernet eth1: PHY [mdio-bus:01] driver [RTL8221B-VB-CG 2.5Gbps PHY]
[ 2888.095066] mtk_soc_eth 15100000.ethernet eth1: configuring for phy/1000base-x link mode
[ 2888.280838] kmwan: Delete node:wan
[ 2930.832159] mtk_soc_eth 15100000.ethernet eth1: Link is Up - 2.5Gbps/Full - flow control rx/tx
[ 2930.840793] IPv6: ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready
[ 2935.260907] [add_dev_config 288]add node success. iface:wan, dev:eth1, ifindex:3
[ 3053.505446] kmwan: Delete node:wan
[ 3053.711953] [add_dev_config 288]add node success. iface:wan, dev:eth1, ifindex:3
[ 3944.679758] nf_conntrack: default automatic helper assignment has been turned off for security reasons and CT-based  firewall rule not found. Use the iptables CT target to attach helpers instead.
[ 4000.820633] mtk_soc_eth 15100000.ethernet eth1: Link is Down
[ 4001.210988] mtk_soc_eth 15100000.ethernet eth1: PHY [mdio-bus:01] driver [RTL8221B-VB-CG 2.5Gbps PHY]
[ 4001.220504] mtk_soc_eth 15100000.ethernet eth1: configuring for phy/1000base-x link mode
[ 4001.405080] kmwan: Delete node:wan
[ 4037.338453] mtk_soc_eth 15100000.ethernet eth1: Link is Up - 2.5Gbps/Full - flow control rx/tx
[ 4037.347079] IPv6: ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready
[ 4040.561555] [add_dev_config 288]add node success. iface:wan, dev:eth1, ifindex:3
[42519.713748] entrytb_aid_aquire(): found non-occupied aid:7, allocated from:4

That's the gl.inet version of Openwrt, we know nothing about it.

Install proper Openwrt, or ask gl.inet.

https://openwrt.org/toh/gl.inet/gl-mt6000


It appears you are using firmware that is not from the official OpenWrt project.

When using forks/offshoots/vendor-specific builds that are "based on OpenWrt", there may be many differences compared to the official versions (hosted by OpenWrt.org). Some of these customizations may fundamentally change the way that OpenWrt works. You might need help from people with specific/specialized knowledge about the firmware you are using, so it is possible that advice you get here may not be useful.

You may find that the best options are:

  1. Install an official version of OpenWrt, if your device is supported (see https://firmware-selector.openwrt.org).
  2. Ask for help from the maintainer(s) or user community of the specific firmware that you are using.
  3. Provide the source code for the firmware so that users on this forum can understand how your firmware works (OpenWrt forum users are volunteers, so somebody might look at the code if they have time and are interested in your issue).

If you believe that this specific issue is common to generic/official OpenWrt and/or the maintainers of your build have indicated as such, please feel free to clarify.

As mentioned before, consider applying the official OpenWRT supported firmware.

When I bought this device, I had about zero interest in running my firewall and router on firmware of a company I'd never heard of that wasn't on American soil. So I bought them with the intention of flashing them before they ever send or received a packet from the internet.

Download this firmware.

https://downloads.openwrt.org/snapshots/targets/mediatek/filogic/openwrt-mediatek-filogic-glinet_gl-mt6000-squashfs-sysupgrade.bin

Then go to the firmware upgrade page and flash this firmware. Must be the sysupgrade version as I linked to. Don't install the factory version or anything except sysupgrade.

If it asks to keep settings, say no. If you don't see this option, wipe the settings and do a reboot. Do not carry any settings over from the GL.iNet version as they are incompatible, and the same if you go back to the GL.iNet version.

Welcome to proper OpenWrt with much better drivers!

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.