Flashing ZyXEL WAP3205 v1, U-Boot doesn't prompt


I am trying to flash my old ZyXEL WAP3205 v1. I did exactly what it says in this description:
Connected to serial interface (using USB to TTL Serial Cable) and can see U-Boot. Description says "When you see U-Boot prompt, press 2:". But U-Boot doesn't prompt me for anything. It selects "3: Boot system code via Flash (default)." without prompting, and boots. I don't know what am I missing.

Description also says " If you miss the bootloader (U-Boot) prompt, wait until ZyXEL Linux boots and issue halt or reboot .". But I don't know how to " issue halt or reboot .". I am using Putty.

Any help will be appreciated.

Did you try pressing 2 right before you expect so see the "3: Boot system code via Flash (default)." ?

I have another ZyXEL device where the menu/prompt is hidden, but it still accepts the input.

Yes I did. But prompt goes too fast, I can not catch it.

By the way, what I am doing is, connect everything but not power on. Connect via putty, then power on. Is that right?

As soon as powering on, prompt goes lightening fast. I tried to press 2 before powering on and continue to press. But could not catch it.

No way. Tried tens of times, could not catch "2". It always selects "3: Boot system code via Flash (default)." without prompting.

Any ideas?