Flashing WRT3200ACM, boots to stock firmware

I bought a WRT3200ACM today, and tried to flash OpenWRT on it. The UI shows the flashing process proceed to the end, and then it reboots the router. But after reboot it's still booting into the stock firmware.

I've downloaded the OpenWRT firmware on the WRT3200ACM page and verified that the download is OK. Unfortunately I can't get much more information from the stock firmware.

What file did you use exactly?

The OpenWRT install, openwrt-19.07.0-mvebu-cortexa9-linksys_wrt3200acm-squashfs-factory.img, from the download link on the wiki page.

Are you sure you are not booting the same partition that was not flashed?

I have no idea how to check which partition I'm booting from in the stock firmware, or if that's even possible. I tried switching firmware partition with the power button method mentioned on the wiki page though.

1 Like

Try a new flash. It automatically starts in the second partition after any type of update or flash.

I've tried flashing OpenWRT three times by now. The same result every time.

I've discovered, and this is indeed the case. I suspect that the router goes through three unsuccesful reboots when trying to switch to the other partition, and ends up on the first partition.

As a test maybe try an older 18.x factory image.

Same thing with 18.06.6... Maybe my router is broken?

Certainly sounds a wee bit borked. You probably need a TTL serial to see what is actually occurring, I don't recall offhand what kind of info the OEM SW provides when flashing.

New OEM FW, is that what it is running

Latest Date:  1/8/2020

wonder if something changed there? Try a different / older flavour.

1 Like

Interesting. That definitely wasn't there when checked the other day, and my router doesn't detect it when I check for updates.

Release notes:

  • Integrated WLAN driver v9.1.2.6 and FW v9.3.2.8
  • Added support for the Marvell Armada 385 Rev. B0 CPU
  • Resolved multiple security vulnerabilities
  • General bug fixes

I'll try installing this one.

Edit: OK, that firmware enabled me to install OpenWRT in some way. I can SSH to the router and OpenWRT is running. LuCI doesn't seem to be available though, and I have (not suprisingly) no internet connection.

When I try to load http:/ I get some files from the server, but then I'm redirected to the Linksys UI ( for some reason. The network tab in Chrome debugger is cleared too fast for me to see what's happening.

Things are going forward, but I was hoping not to have to do the initial setup in the command line.

Usually that kind of thing is due to browser cache...

If you installed a snapshot, LuCI is not included.
(It is only included by default in the releases)
You need to install it via opkg.

I figured that out, eventually. Now I'm up and running.

Thanks everyone for your help!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.