Flashing OpenWrt on Netgear Nighthawk R8000

Hi! I see here and on this forum that openwrt is now fully compatible with this model:
https://openwrt.org/toh/netgear/r8000#tab__firmware_downloads

But I don't understand how can I install... Anyone has already do?

The device has very little (OpenWrt specific) information around it, but it's quite likely that you can just install it from the OEM firmware. In the worst case using tftp push-button recovery for installing OpenWrt might be an option.

1 Like

I'm running OpenWRT on my R8000. The biggest hurdle is getting past Netgear's attempt to stop you from installing "older" firmware. They do this by doing a simple version check. Unfortunately this will stop you from installing the stock OpenWRT image you can download.

There is a patch for OpenWRT that fixes the version number issue. So you can build a patched version for the R8000, or you can build a stripped down patched version that will then let you install the version linked above. More details are in a thread on a different site: How to flash the Netgear R8000. Go to page two for the gory details. There you'll see what worked for me.

I originally built the patched version so I could then flash tomato but after a week or so I decided to give OpenWRT a try and have never looked back. I did hedge my bets by buying a 2nd, used R8000 off eBay to test with. Also, when moving from tomato to OpenWRT on my 1st router I soft bricked it and then required a USB-TTL cable to be able to flash via tftp to recover. I've made the mistakes and now have OpenWRT on both routers, so feel free to ask me questions.

Oh perfect thanks! I recently have a little bit problem with the lastest version about stock firmware and Netgear hint me to do a downgrade of firmware only flashing via web gui a previous version... It could be that this problem doesn't exist anymore?

If I try anyway flashing via gui chk file, Brick risk?

The Netgear R8000 will not allow you to downgrade to a previous version of of Netgear firmware. The only thing it will let you do us upgrade to future Netgear released firmware. You never know when or if Netgear will fix the problem you are having. The only problems I've found with OpenWRT 18.06.2 on the R8000 is USB3 support for my USB3 hard drive and NFS support is missing.

What is the problem you're having with the current Netgear firmware?

After 3 exchange of R8000 with amazon and updated to lastest version I decided to keep this router because I thought is a software bug as someone told me in a telegram group. The second 5ghz band works intermittently and the Netgear assistance told me to download from the official website a previous version.
I downloaded the chk file and flashed via web gui without any kind of problem.

For this reason for me is strange the "anti downgrade system"

So are you good now or do you still want to install OpenWRT?

I still want to install OpenWRT. But what I would like to know is: “in the worst of the hypothesis what can happen if I try to upload the file without any other data? It seems that know I don’t have any downgrade problem...

If the router has a functional TFTP recovery (and most Netgears seem to have it; but you need to confirm for your specific model) you're good. Netgear's boot loader often (maybe always; but I only have experience with the WNDR3700) comes with a TFTP server you can upload a recovery image (be it OpenWrt or Netgear's own firmware) to.

I don't think you'll be able to install the stock OpenWRT image. I think you'll get: "The Firmware Is Not Compatible With Your Router. Error -1". If that happens, you're still on the OEM Netgear firmware and you'll have to build a version that includes the patch I referenced above.

I have OpenWRT running on my R8000 and I doubt I'm the only one so no downside to loading OpenWRT. As I mentioned, only USB3 and NFS are problems for me. I have multiple VLANs, a guest WLAN, adblock and samba (NAS for windows clients, but at USB2 speeds only) running. I've been too lazy to try one of the snapshots to see if USB3 and NFS are fixed. I was able to get everything configured the way I wanted using just the available docs and I'm no router or networking expert.

I have only used TFTP via the serial interface. It's quite easy except taking the case off the router takes a little time. There's two pieces that need to come off and you will probably need to disconnect the six antennas. If you go the serial interace route you'll need a USB-TTL cable. They cost about $10 here in the US. If it comes to that I can walk you through it. It only happened to me trying to flash OpenWRT from tomato. I'm not sure what I did wrong.

Perfect! Thanks so in case of brick I'll use TFTP!

I read carefully your link, so should I follow the shaithus procedure? If yes how can I do in linux or windows the point 3 and four?

Windows isn't case sensitive so if you use windows you will want to install something like VirutualBox from Oracle. It's free. VirtualBox will let you setup a virtual machine (VM) and install and run linux in a virtual machine. I suggest the Ubuntu 18.04 desktop release. You can download the iso image and link to the iso from the VM via Devices->Optical Drives->Choose disk image. Restart the VM and it will automatically start the install of Ubuntu. You will build the patched version of OpenWRT in linux.

Once you have Ubuntu running in a VM then you are at step 3 in the instructions. The brew command is specific to OSX on a Mac. If you read the README file that is part of the OpenWRT source on github, I believe it tells you all packages you need to install on Linux. I was lazy and did it by trial and error by looking at failed dependencies but it's smarter and faster to read the doc. Alternatively if you have a spare laptop or PC you can install Ubuntu, or other linux distro, on it and use it to teach yourself a little about linux. If you have a buddy that is linux savvy, maybe invite him over for a few beers and work through the build together.

I never had any luck with shaithus' step 10 using nmrpflash. I tried dozens of times and never got it right. You shouldn't need to do steps 9 or 10 anyway because you do have a working web interface in the stock Netgear firmware right now. Go to step 11 and continue. On step 13 plug directly into your ISP provided interface, cable modem or ONT and continue. Follow the rest of the steps to install luci and when complete you will have functioning router and the wired ports will be active. The three radios will not be enabled by default. You will have to enable all three, set up security and SSIDs etc. There is no guest WLAN setup by default in OpenWRT. You will need to read the doc to figure out how to do that. Let me know if you have issues with the guest WLAN.

If you have kids and want to add some of the child access features built in to the stock Netgear firmware you will want to start with changing the DNS servers for the WAN. Using the OpenDNS servers was one of the options in the stock Netgear firmware. I use the quad9 DNS servers but there are many choices in DNS servers. You may want to look at the adblock package and use it to block ad, malware, and other crap you don't want you or your family to be bothered with. After that, if you have additional needs, explore the packages and/or post a question asking how to accomplish your task.

You can install ubuntu in windows 10 it's called wsl. No need for VMs and all that stuff. I build openwrt under WSL.

Hi! I'm trying now to compile but I get an error:
"make -r world: build failed. Please re-run make with -j1 V=s or V=sc for a higher verbosity level to see what's going on
/root/openwrt/include/toplevel.mk:216: recipe for target 'world' failed
make: * [world] Error 1"

these are the step that I do:

  1. VirtualBox + Ubuntu 18.04
  2. apt install --> gcc, binutils, bzip2, flex, python, perl, make, find, grep, diff,
    unzip, gawk, getopt, subversion, libz-dev. Some dubs with libc headers (How can I install? )
  3. apt install subversion g++ zlib1g-dev build-essential git python time
    apt install libncurses5-dev gawk gettext unzip file libssl-dev wget
    apt install libelf-dev
    apt install build-essential libncurses5-dev python unzip
  4. git clone git clone https://github.com/willson556/openwrt.git
  5. ./scripts/feeds update -a
  6. ./scripts/feeds install -a
  7. make menuconfig
  8. ->Target System->Broadcom BCM47xx/53xx (ARM)
    ->Target Profile->NetGear R8000
  9. make
  10. ERROR: (this is outout of make)
    make[1] world
    make[2] tools/compile
    make[3] -C tools/flock compile
    make[3] -C tools/xz compile
    make[3] -C tools/sed compile
    make[3] -C tools/patch compile
    make[3] -C tools/tar compile

3.5 su "user"

sorry I don't understand

You're in root folder and running administrative commands, are you running as superuser?

yes, in fact now I'm trying without root

I don't think you understand.

On Ubuntu, the command is sudo apt install

1 Like