Flashing of firmware by LUCI takes forever to finsh (ZBT we826)


I tried to flash firmwares by LUCI several times, but it takes like forever and never finished.

Can anyone give me a hint?

Thank you,


  • What device are you using?
  • Have you tried using the command line to use the sysupgrade command instead?
  • When you say

Does that mean the device never reboots?

I am using ZBT we826,

I haven't tried command line yet, but my application requires to use LUCI to upgrade.

Yeah, my device never reboots.

Please help me out,

Thank you,

Mind to tell us which?

WE-826 is my workhorse. Doing upgrades almost every day, for testing new features in customized images ( But only using cmd-line.
No problem at all.
So you might file a bug.

1 Like

My firmware is built by myself which is Lede17.1.0.4

Yes, I tried to use sysupgrade -v /tmp/*bin too.
But then nothing seems to be working, actually I don't know what is going on because all shells are closed.

I then waited for few minutes then tried to reconnect and hoped the new firmware is loaded, but it wasn't.

then I disconnected the power, and put the power back on, it came back to operation but with the old firmware, (not the one I am trying to load).

Please help me out,


There is no special "LuCI sysupgrade". LuCI uses the same underlying sysupgrade script that can be run from console.

You might need to attach a serial cable to the motherboard to see the possible error messages after the network connections are shut down.

1 Like

Usually, I do not keep the settings. So, just for a try, do
cd /tmp
#Kill any special processes manually, you might have
#Is /tmp large enough ?
#you might expand its size
sysupgrade -n -v /tmp/fw.bin

Does this work ?

There is no special processes running in mine,
I have my /tmp large enough,

I will try sysupgrade -n -v /tmp/fw.bin
and let you know.

Now, it said:
"Commencing upgrade. All shell sessions will be closed now."

Now I am trying to connect by LUCI or puTTy with no success.

Give me your email. Just for a try, I can send you my simple image tomorrow. Without LuCi, which I (almost) never use.
OR try to connect serial cable, to get more info. As "Commencing upgrade. All shell sessions will be closed now." looks good.

I've got it work, :), I have to wait like 20 mins before it is done.

Thank you very much,


20 min. ? Still something wrong.

Usually, how long should it be?

About 1 minute until reboot.

How big is your image? Mine is around 12MB.


Why is your image so large????

Your router only has 16 MB flash...this is likely the issue. Most OpenWrt images are no larger than 6MB. Have you simply tried the image from downloads.openwrt.org?

I have about 4.5MB; no LuCi. 12MB ... dunno whether will fit ... unless you have the WE326 with 32MB flash ...

1 Like