Flashing Netgear Nighthawk AC2600 / R7800

Hello, I am trying to install OpenWrt on my Nighthawk but cannot get the tftp to work, serial no: 5rm612bwa0023. I follow these instructions: https://openwrt.org/toh/netgear/r7800.
I tried on a Windows computer with tftpd64 and on a Mac with the terminal tftp. I even reloaded the router firmware from netgear version AC2600_V1.2.0.90_1.0.1. The tftp just times out. I tried to increase the timeout to 24000 with no luck. mac ip 192.168.1.10, tftp tp 192.168.1.1. I also tried to tftp the real factory image renaming it factory.img with no luck.
Please help, I am getting cramps form holding the reset button with a paper clip.
Thanks

Common issues usually include:

  • your PC firewall blocking the tftp client
  • wrong IP addresses being configured/ used
  • powering off the router causes a reconnect, with link-training and maybe losing the IP address on the computer in the process, putting a simple unmanaged switch between router and PC can avoid that

Netgear's push-button tftp recovery tends to be very reliable.

Hey, thanks for the good advice. I will definitely check the firewall issue. I used 192.168.1.10 for the MAC and 192.168.1.1 for the router. I did see the mac disconnect when pressing the reset, I had the network config window open, I believe it did reconnect but I am not sure.

I will give it another try with a Linux machine, where I have better control over the network. I will aslo try the unmanaged switch as I have one.

All the best

I found the problem, human error and I am the human. My model is AC2600 not X4S AC2600 R7800. It is not supported.
Thanks for everything.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.