Flashing LEDE on AR9331 4MB Router - USB Support

Hello!

I'm eager to try LEDE for my 4MB Flash TP-Link WR741ND v4.25 and I got here on the forum following the recommendation form the quick-start guide.
I'm currently running OpenWRT openwrt-15.05.1-ar71xx-generic and having issues with my modded AR9331 Chip. I got the USB wires out and found out that there are kernel support issues in OpenWRT, therefore I'd like to test it with LEDE. I tried to flash the OpenWRT TP-Link MR3220 (which has the same AR9331 Chip and has USB Onboard) image and got it working without issues, but the USB was still faulty.
Everything I got while connecting USB devices was:
[ 721.020000] usb 1-1: new full-speed USB device number 2 using ehci-platform
[ 721.240000] usb 1-1: device descriptor read/64, error -71
[ 721.560000] usb 1-1: device descriptor read/64, error -71
[ 721.790000] usb 1-1: new full-speed USB device number 3 using ehci-platform
[ 722.010000] usb 1-1: device descriptor read/64, error -71
[ 722.330000] usb 1-1: device descriptor read/64, error -71
[ 722.560000] usb 1-1: new full-speed USB device number 4 using ehci-platform
[ 723.040000] usb 1-1: device not accepting address 4, error -71
[ 723.160000] usb 1-1: new full-speed USB device number 5 using ehc

Personally, although some suggested to try to connect the USB devices through an USB Hub (which I tried with 3 different ones without any success), I believe that while the OpenWRT working images were based on the AR9331 AL1A chip, mine is AL3A and it may have some newer/different USB engine.
There is a ticket on OpenWRT covering this:
https://dev.openwrt.org/ticket/16505

Now, I'd like to be able to return to OpenWRT if I fail with LEDE and I'm not sure how to do this without bricking my Router. I learned that in order to upgrade from my OpenWRT image to LEDE, I just need to flash it with the LEDE upgrade bin.
Will this work on my actual OpenWRT image:
cd /tmp
wget http://link-to-LEDE-image.bin
mtd -r write /tmp/http://LEDE-image.bin firmware

And to revert it back to OpenWRT, can I then under LEDE run:
cd /tmp
wget http://downloads.openwrt.org/chaos_calmer/15.05.1/ar71xx/generic/openwrt-15.05.1-ar71xx-generic-tl-wr741nd-v4-squashfs-sysupgrade.bin
(or factory image ?)
mtd -r write /tmp/openwrt-15.05.1-ar71xx-generic-tl-wr741nd-v4-squashfs-sysupgrade.bin firmware

Do I need to revert it first back to original TP-Link flash after LEDE? I'm a little bit afraid to do that because I have some new version of official firmware and I'm not sure if it will allow me to rewrite OpenWRT again (it might have some sort of protection). Additionally, as I've always failed to flash through LuCI (don't know why), I'm always wget-ing the image in /tmp and writing it with mtd -r write. If I cannot wget the official TP-Link flash in tmp, then I might have a problem, because I don't know how to transfer it to the router from my desktop computer without complications - like setting up a TFTP server - not impossible, but pretty complicated.

I'd be very thankful if someone more experienced could help me out with this.