Flashing GL.iNet GL-B1300 with OpenWrt 18.06.1


#1

https://openwrt.org/toh/hwdata/gl.inet/gl.inet_gl-b1300
Comment installation:
Can't directly flash OWrt 18.0 from stock firmware's web interface and sysupgrade

So my question is, how do I flash a brand new GL.iNet GL-B1300 with OpenWrt 18.06.1?
Installed is Firmware 2.272 and in the advance section I see Chaos Calmer 15.05.1

I found https://forum.gl-inet.com/t/b1300-unable-to-update-to-lede/3032/ which mentions a lot of probelms, but not with OpenWrt 18.06.1.

Unfortunately I didn't find a howto for flashing at GL.iNet, what have to be done exactly.

So can anyone tell me what works?

My first problem is, that I cannot connect with an ethernet-cable to a notebook, but via Wifi.

Which port do I have to use, when I connect via ethernet cable, wan or lan?


#2

GL-iNet B1300 flashing OpenWrt
#3

Thanks for mentioning https://github.com/openwrt/openwrt/commit/04d3308b6248ef21a6f0bc3378b342906c2d2865

Actually I have no idea, how to do it.

Method 2 looks a little bit easier for me.

Method 2:

  • push down reset button and power on
  • wait until three leds constantly on then release
  • upgrade by uboot web at http://192.168.1.1
    Note:
  • the sysupgrade image need to be renamed to lede-gl-b1300.bin in both method.
  • the sysupgrade image can be automatically downloaded if tftp server at
    192.168.1.2 have that file.
  • the wifi led will be flashing when writing image.

I don't trust the automatical download. Where can I download the file and what is the next step then? Links to read are welcome.