Flashing an original Asus RT-AX53U using scp?

Not necessary, it worked to connect the Asus WAN-port with an Ethernet-port of an Archer C7, which is wireless wds-client.

I did not get it work to configure ssh with the original-FW without Internet. But the connection above did the job, including an Asus-FW-Update to 3.0.0.4.386

But then you have to know some things which is different to the wiki.

After enabling ssh you have to reboot the rooter. I tried a lot ssh connections and was blocked at the end.

You have to define a router account-name and this is the local part for ssh, not admin or root. I don't know if this must be lower case, did it at the end after trying a lot things.

SSH-Keys worked with the correct local part, which you configured before as "router account".

Take care, if you have configured more network-connections with your pc to be always in the "Asus-net".

Since I had an internet connection, I did it as described in the wiki, was not adventorous and tried scp. Especially I was unsure which target path to use, probably it should be /tmp/home/root/.

ax-53@RT-AX53U-0EC8:/tmp/home/root# wget https://downloads.openwrt.org/releases/
22.03.5/targets/ramips/mt7621/openwrt-22.03.5-ramips-mt7621-asus_rt-ax53u-squash
fs-factory.bin
--2023-12-21 15:17:56--  https://downloads.openwrt.org/releases/22.03.5/targets/ramips/mt7621/openwrt-22.03.5-ramips-mt7621-asus_rt-ax53u-squashfs-factory.bin
Resolving downloads.openwrt.org... 199.232.18.132, 2a04:4e42:41::644
Connecting to downloads.openwrt.org|199.232.18.132|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 9568256 (9.1M) [application/octet-stream]
Saving to: 'openwrt-22.03.5-ramips-mt7621-asus_rt-ax53u-squashfs-factory.bin'

openwrt-22.03.5-ram 100%[===================>]   9.12M  4.85MB/s    in 1.9s    

2023-12-21 15:17:59 (4.85 MB/s) - 'openwrt-22.03.5-ramips-mt7621-asus_rt-ax53u-squashfs-factory.bin' saved [9568256/9568256]

Then:

ax-53@RT-AX53U-0EC8:/tmp/home/root# mtd-write -i openwrt-22.03.5-ramips-mt7621-asus_rt-ax53u-squashfs-factory.bin -d Kernel

Is done very quickly.

ax-53@RT-AX53U-0EC8:/tmp/home/root# reboot

I think this didn't work. I waited 5 minutes and then switched the rooter off and on. Be careful to change the network now to the openwrt-net.

If the old router is one which has the 1st radio with 5GHz, the Asus has 2.4 GHz as 1st radio. Took a while until I found out, why wds did not work because of the changed radios.